0

I hope some of you can help me with that problem. It is however difficult to give a minimal example. Here is the Problem:

I'm writing my master's thesis with TEXmaker and have splitted my document by using the \input command. The compilation always worked fine. But suddenly there is the error message

! Missing number, treated as zero. \advance l.15 ...egion (MP).\relax }}{29}{table.caption.28} A number should have been here; I inserted `0'.

appears. The text location given in the message hasn't been changed and worked before. And the strange thing is, when I masked all inputs with % the compilation worked fine, I removeed the %again, the compilation still worked fine. I ran BIBTEX and PDFLATEX and it worked fine. I ran PDFLATEX for the last time (as it is recommended to get all refences right) the error appeared again with the identical message.

I again masked all inputs and ran PDFLATEX, the error remained. I repeated PDFLATEX, now it worked again though I haven't changed the code.

Please, does anyone know this weird error? It started when I used the "Fast Translate" (PDFLATEX + BIB(LA)TEX + 2x PDFLATEX + View PDF) in TEXmaker

  • Sorry, but without a minimal working example, this is impossible to answer. Take a close look at your table captions and delete the aux-files between checking. – Johannes_B Sep 27 '15 at 11:15
  • The thing is, when I remove the part given in the error message and compile, the same message comes. When I compile again then the error message shows me another part of the code. And the line number given by the message is different from the line in which the code fragment is :-( – Thesiswriter Sep 27 '15 at 11:23
  • 1
    There is an error in the code, and we don't know your code. A simple algorithm to find the cause (<- Link) is availabe to help you. – Johannes_B Sep 27 '15 at 11:35
1

(this was intended as a comment, but it's too long.)

the problem appeared with the fourth run. that means it happened because of some change that was made with the third run.

so what happened in the third run?

pdflatex was run after biblatex, and that made the information on the \cites available in the .aux file. so the problem is almost certainly associated with one of the \cites, but surely by something in the .aux file.

look in the line where the problem is reported and see if there's some sort of cross reference. is it in a "moving argument" like a section heading or a caption? if so, there are other questions here dealing with that.

the solution in such a case is usually to add \protect before the \cite or \ref in the argument. but we can't be specific without an example to experiment with.

0

To speed up my compilation I exclueded parts with %, for example the titlepage added with

\pagenumbering{Roman}
\setcounter{page}{-1}
\begin{titlepage}
\input{../Titlepage/Titlepage}
\thispagestyle{empty}
\newpage
\end{titlepage}

However I only masked the the entrys from begin to end titlepage. When I also mask the setcounter to %\setcounter{page´}{-1}the code finally worked again.

I really don't know why the error sometimes appeared not before the fourth compilation run.

Thanks for you motivation, Johannes_B

  • 1
    this isn't an answer; it should be incorporated in the question. – barbara beeton Sep 27 '15 at 12:27
  • Well but it solved my problem. So isn't this the solution? – Thesiswriter Sep 27 '15 at 13:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.