0

Has there been a recent update to the fontspec package which changed the usage of \setmainfont in LaTeX or XeLaTeX? This seems to be the same error as in this post today: unicode-math broken

I updated my Tex Live installation and I'm now receiving an error for the following MWE.

\documentclass{scrartcl}
\usepackage{fontspec}
\setmainfont{Times}[ItalicFont={Gill Sans Italic}]

\begin{document}
\end{document}   

The error from my log is

(/usr/local/texlive/2015/texmf-dist/tex/latex/fontspec/fontspec.cfg)))
./MWE.tex:4: Undefined control sequence.
<argument> \xetex_suppressfontnotfounderror:D 

l.4 ...nfont{Times}[ItalicFont={Gill Sans Italic}]

The control sequence at the end of the top line
of your error message was never \def'ed. If you have
misspelled it (e.g., `\hobx'), type `I' and the correct
spelling (e.g., `I\hbox'). Otherwise just continue,
and I'll forget about whatever was undefined.
  • Indeed, it would appear to be the same error. Have you tried the emergency patch David Carlisle has provided to the query given in the link you've provided? – Mico Sep 28 '15 at 1:19
  • @Mico Yes, I have just tried that and it appears to work as well. Not very satisfying though... :) – tim Sep 28 '15 at 1:36
  • A patch of the misbehaving package, or packages, should be pushed out soon. – Mico Sep 28 '15 at 2:16
  • @joseph-wright fontspec.sty does not have unicode-math as a dependency. It's the same error as both point to xetex; has there been some significant change to XeTeX? – tim Sep 29 '15 at 3:57
  • @tim The errors are caused by the same thing: a typo in expl3. – Joseph Wright Sep 29 '15 at 5:43

Browse other questions tagged or ask your own question.