1

I'm trying to upgrade all my packages with Tex Live Utility on OS X Yosemite (10.10.5) running MacTeX-2015 on a MacBook Pro.

Package by package the installation went well, until the very end, when I saw the following in the last few lines of the log:

2015-09-28 12:40:24 +0000 Notice tlu_ipctask[55705] Installation complete; reconfiguring TeX Live
2015-09-28 12:40:27 +0000 Warning tlu_ipctask[55705]    done running mktexlsr.
2015-09-28 12:40:27 +0000 Warning tlu_ipctask[55705]    running mtxrun --generate ...
2015-09-28 12:40:31 +0000 Warning tlu_ipctask[55705]    done running mtxrun --generate.
2015-09-28 12:40:31 +0000 Warning tlu_ipctask[55705]    running updmap-sys ...
2015-09-28 12:40:37 +0000 Warning tlu_ipctask[55705]    done running updmap-sys.
2015-09-28 12:40:37 +0000 Warning tlu_ipctask[55705]    regenerating fmtutil.cnf in /usr/local/texlive/2015/texmf-dist
2015-09-28 12:40:37 +0000 Warning tlu_ipctask[55705]    running fmtutil-sys --no-error-if-no-engine=luajittex --no-error-if-no-format --byengine pdftex ...
2015-09-28 12:41:03 +0000 Warning tlu_ipctask[55705]    done running fmtutil-sys --no-error-if-no-engine=luajittex --no-error-if-no-format --byengine pdftex.
2015-09-28 12:41:03 +0000 Warning tlu_ipctask[55705]    running fmtutil-sys --no-error-if-no-engine=luajittex --no-error-if-no-format --byengine aleph ...
2015-09-28 12:41:05 +0000 Warning tlu_ipctask[55705]    done running fmtutil-sys --no-error-if-no-engine=luajittex --no-error-if-no-format --byengine aleph.
2015-09-28 12:41:05 +0000 Warning tlu_ipctask[55705]    running fmtutil-sys --no-error-if-no-engine=luajittex --no-error-if-no-format --byengine ptex ...
2015-09-28 12:41:06 +0000 Warning tlu_ipctask[55705]    done running fmtutil-sys --no-error-if-no-engine=luajittex --no-error-if-no-format --byengine ptex.
2015-09-28 12:41:06 +0000 Warning tlu_ipctask[55705]    running fmtutil-sys --no-error-if-no-engine=luajittex --no-error-if-no-format --byengine eptex ...
2015-09-28 12:41:10 +0000 Warning tlu_ipctask[55705]    done running fmtutil-sys --no-error-if-no-engine=luajittex --no-error-if-no-format --byengine eptex.
2015-09-28 12:41:10 +0000 Warning tlu_ipctask[55705]    running fmtutil-sys --no-error-if-no-engine=luajittex --byfmt dvilualatex ...
2015-09-28 12:41:12 +0000 Warning tlu_ipctask[55705]    done running fmtutil-sys --no-error-if-no-engine=luajittex --byfmt dvilualatex.
2015-09-28 12:41:12 +0000 Warning tlu_ipctask[55705]    running fmtutil-sys --no-error-if-no-engine=luajittex --byfmt lualatex ...
2015-09-28 12:41:15 +0000 Warning tlu_ipctask[55705]    done running fmtutil-sys --no-error-if-no-engine=luajittex --byfmt lualatex.
2015-09-28 12:41:15 +0000 Warning tlu_ipctask[55705]    running fmtutil-sys --no-error-if-no-engine=luajittex --byfmt pdfcsplain ...
2015-09-28 12:41:17 +0000 Warning tlu_ipctask[55705]    done running fmtutil-sys --no-error-if-no-engine=luajittex --byfmt pdfcsplain.
2015-09-28 12:41:18 +0000 Notice -[TLMAuthorizedOperation _runUntilChildExit][55339]    kqueue noted that pid 55706 exited (/usr/texbin/tlmgr --repository http://mirror.math.ku.edu/tex-archive/systems/texlive/tlnet/ --machine-readable --persistent-downloads update --all)
2015-09-28 12:41:18 +0000 Notice tlu_ipctask[55705] child process pid = 55706 exited
2015-09-28 12:41:19 +0000 Error tlu_ipctask[55705]  Value of errno is Operation not permitted
2015-09-28 12:41:19 +0000 Error tlu_ipctask[55705]  *** ERROR *** exit status of pid = 55706 was 1
2015-09-28 12:41:19 +0000 Notice -[TLMAuthorizedOperation _runUntilChildExit][55339]    waitpid returned 55705, WIFEXITED(256) = 1, errno = 1 (Operation not permitted)
2015-09-28 12:41:19 +0000 Notice -[TLMAuthorizedOperation _runUntilChildExit][55339]    kqueue noted that tlu_ipctask (pid = 55705) exited with status 1

Why am I getting this error, and how can I resolve it?

  • 2
    I think this has to do with the new security features in OS X that limit even root's ability to modify files under /usr. It's a big change in OS X 11, but already started with the 10.10.5 upgrade, which resets the permissions on /usr/local to read-only (and in particular, removes the x bit for directories). You could try a judicious chown -R $USER:admin /usr/local/texlive (where $USER is you username) and retry (without sudo). – Christian Clason Sep 28 '15 at 17:30
  • 1
    Sorry for the trouble, but I'm not sure what's going on here; I haven't seen this problem with my Yosemite installation. If the problem persists, please file a bug report and include the full log. github.com/amaxwell/tlutility/issues – Adam Maxwell Oct 11 '15 at 0:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.