3

I used acro package with tabular style to print acronyms. When I did that, it added an extra line to the end of acronyms list, therefore \vspace{-\baselineskip} corrects the problem. However that extra line should not be added, which do not happen if you use a description-like environment.

\documentclass{article}

\usepackage{acro}
\acsetup{list-style=tabular} % commented gives the list style
\DeclareAcronym{UHF}{%
    short={UHF},
    long={Ultra High Frequency},
    }
\DeclareAcronym{RF}{%
    short={RF},
    long={Radio Frequency},
    }

\begin{document}

\section{Introduction}

\ac{UHF}\ac{RF}


\printacronyms[heading=section]
%\vspace{-\baselineskip} % fixes spacing with 'list-style=tabular'

\section{Conclusion}

\end{document}
  • There is an empty paragraph at the end but it's quite unclear where it comes from… – cgnieder Sep 29 '15 at 7:43
  • It does not exist when you use the lists. Is there any additional \\' in the tabular/longtable/tabularx` definition? – cacamailg Sep 29 '15 at 12:57
  • No there isn't. As I said: it's quite unclear where it comes from – cgnieder Sep 29 '15 at 13:18
  • The more I investigate the less idea I have where this is coming from… :( – cgnieder Nov 8 '15 at 12:34
  • I would suggest a temporary workaround, the same way I did in my MWE. – cacamailg Nov 9 '15 at 11:23
2

This is fixed in v2.6e (2016/09/04):

\documentclass{article}

\usepackage{acro}[2016/09/04]
\acsetup{list-style=tabular}

\DeclareAcronym{UHF}{
  short = {UHF} ,
  long = {Ultra High Frequency}
}
\DeclareAcronym{RF}{
  short={RF},
  long={Radio Frequency}
}

\begin{document}

\section{Introduction}

\ac{UHF}\ac{RF}

\printacronyms[heading=section]

\section{Conclusion}

\end{document}

enter image description here

  • I tried it with tabular and it worked. But I tried it with tabu (following the example in the documentation) but it didn't work as expected. The gap between section head and the list itself is too huge. – cacamailg Sep 19 '16 at 19:08
  • If you believe there is something buggy please make a bug report with minimal example bitbucket.org/cgnieder/acro/issues – cgnieder Sep 19 '16 at 19:12
  • Ok. Added already. – cacamailg Sep 19 '16 at 19:32
  • @cacamailg Thanks. There is nothing acro can do. I added an example to the issue you opened that shows that the space is caused by longtabu itself. You could maybe use the before option when defining the style adding some negative vertical space. – cgnieder Sep 20 '16 at 10:09
  • Thanks. I added a code below which I think works as expected. – cacamailg Sep 20 '16 at 14:43
0

With the code below it seems to work as expected.

\documentclass{article}

\usepackage{tabu,longtable}
\usepackage{acro}[2016/09/04]
\DeclareAcroListStyle{longtabu}{table}{
    table = longtabu ,
    table-spec = @{}lX@{},
    before={%
        \setlength{\LTpre}{0pt}%
        \setlength{\LTpost}{0pt}%
    }
}   

\DeclareAcroListStyle{newtabular}{table}{
    table = tabular ,
    table-spec = @{}lp{.7\linewidth},
}

\DeclareAcronym{UHF}{
  short = {UHF} ,
  long = {Ultra High Frequency}
}
\DeclareAcronym{RF}{
  short={RF},
  long={Radio Frequency}
}

\begin{document}

\section{Introduction}

\ac{UHF} \ac{RF}

\acsetup{list-style=newtabular}

\printacronyms

\section*{Acronyms}

\begin{tabular}{@{}lp{.7\linewidth}}
  RF  & Radio Frequency \\
  UHF & Ultra High Frequency
\end{tabular}

\acsetup{list-style=longtabu}

\printacronyms


\section*{Acronyms}

\setlength{\LTpre}{0pt}
\setlength{\LTpost}{0pt}
\begin{longtabu}{@{}lX@{}}
  RF  & Radio Frequency \\
  UHF & Ultra High Frequency
\end{longtabu}

\end{document}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.