3

I recently reinstalled both LyX and MiKTeX (on Win10, if it matters), hoping to fix a longstanding error where I couldn't export to pdf via pdflatex. Now, instead, no pdf exports work. It reports that it was successful, but no actual output is created. Exporting to .tex and .html (picked at random) both work just fine, but LuATeX also doesn't work and used to work just fine.

I have tried:

  • Uninstalling and reinstalling MiKTeX (v2.9) as admin and as local user
  • Uninstalling and reinstalling LyX (v2.1.4)
  • Running pdflatex directly via the command line worked on a simple "hello world" example (with \begin{document} but no other content) but did not work on my resume (which the error log below is for). Additionally, using LyX to attempt to pdf-output "Hello world" with no LaTeX preamble visible still fails.
  • Running some other commands via the command line that, frankly, I don't understand, which is okay because it didn't work anyway.

Log of the pdflatex export, in case it helps? It's all Greek to me.

This is pdfTeX, Version 3.1415926-2.3-1.40.12 (MiKTeX 2.9 64-bit) (preloaded format=pdflatex 2015.9.29)  29 SEP 2015 02:55
entering extended mode
**resume.tex

(C:\Users\User\AppData\Local\Temp\lyx_tmpdir.KNAPBAcL2240\lyx_tmpbuf0\resume.tex
LaTeX2e <2015/01/01> patch level 2
Babel <3.9m> and hyphenation patterns for 69 languages loaded.

(C:\MiKTeX\tex\latex\base\article.cls
Document Class: article 2014/09/29 v1.4h Standard LaTeX document class
(C:\MiKTeX\tex\latex\base\size11.clo
File: size11.clo 2014/09/29 v1.4h Standard LaTeX file (size option)
)
\c@part=\count79
\c@section=\count80
\c@subsection=\count81
\c@subsubsection=\count82
\c@paragraph=\count83
\c@subparagraph=\count84
\c@figure=\count85
\c@table=\count86
\abovecaptionskip=\skip41
\belowcaptionskip=\skip42
\bibindent=\dimen102
) (C:\MiKTeX\tex\latex\base\inputenc.sty
Package: inputenc 2015/03/17 v1.2c Input encoding file
\inpenc@prehook=\toks14
\inpenc@posthook=\toks15
(C:\MiKTeX\tex\latex\base\latin9.def
File: latin9.def 2015/03/17 v1.2c Input encoding file
)) (C:\MiKTeX\tex\latex\geometry\geometry.sty
Package: geometry 2010/09/12 v5.6 Page Geometry
(C:\MiKTeX\tex\latex\graphics\keyval.sty
Package: keyval 2014/10/28 v1.15 key=value parser (DPC)
\KV@toks@=\toks16
) (C:\MiKTeX\tex\generic\oberdiek\ifpdf.sty
Package: ifpdf 2011/01/30 v2.3 Provides the ifpdf switch (HO)
Package ifpdf Info: pdfTeX in PDF mode is detected.
) (C:\MiKTeX\tex\generic\oberdiek\ifvtex.sty
Package: ifvtex 2010/03/01 v1.5 Detect VTeX and its facilities (HO)
Package ifvtex Info: VTeX not detected.
) (C:\MiKTeX\tex\generic\ifxetex\ifxetex.sty
Package: ifxetex 2010/09/12 v0.6 Provides ifxetex conditional
)
\Gm@cnth=\count87
\Gm@cntv=\count88
\c@Gm@tempcnt=\count89
\Gm@bindingoffset=\dimen103
\Gm@wd@mp=\dimen104
\Gm@odd@mp=\dimen105
\Gm@even@mp=\dimen106
\Gm@layoutwidth=\dimen107
\Gm@layoutheight=\dimen108
\Gm@layouthoffset=\dimen109
\Gm@layoutvoffset=\dimen110
\Gm@dimlist=\toks17
(C:\MiKTeX\tex\latex\geometry\geometry.cfg)) (C:\MiKTeX\tex\latex\amsfonts\amss
ymb.sty
Package: amssymb 2013/01/14 v3.01 AMS font symbols
(C:\MiKTeX\tex\latex\amsfonts\amsfonts.sty
Package: amsfonts 2013/01/14 v3.01 Basic AMSFonts support
\@emptytoks=\toks18
\symAMSa=\mathgroup4
\symAMSb=\mathgroup5
LaTeX Font Info:    Overwriting math alphabet `\mathfrak' in version `bold'
(Font)                  U/euf/m/n --> U/euf/b/n on input line 106.
)) (C:\MiKTeX\tex\latex\amsmath\amsmath.sty
Package: amsmath 2013/01/14 v2.14 AMS math features
\@mathmargin=\skip43
For additional information on amsmath, use the `?' option.
(C:\MiKTeX\tex\latex\amsmath\amstext.sty
Package: amstext 2000/06/29 v2.01
(C:\MiKTeX\tex\latex\amsmath\amsgen.sty
File: amsgen.sty 1999/11/30 v2.0
\@emptytoks=\toks19
\ex@=\dimen111
)) (C:\MiKTeX\tex\latex\amsmath\amsbsy.sty
Package: amsbsy 1999/11/29 v1.2d
\pmbraise@=\dimen112
) (C:\MiKTeX\tex\latex\amsmath\amsopn.sty
Package: amsopn 1999/12/14 v2.01 operator names
)
\inf@bad=\count90
LaTeX Info: Redefining \frac on input line 210.
\uproot@=\count91
\leftroot@=\count92
LaTeX Info: Redefining \overline on input line 306.
\classnum@=\count93
\DOTSCASE@=\count94
LaTeX Info: Redefining \ldots on input line 378.
LaTeX Info: Redefining \dots on input line 381.
LaTeX Info: Redefining \cdots on input line 466.
\Mathstrutbox@=\box26
\strutbox@=\box27
\big@size=\dimen113
LaTeX Font Info:    Redeclaring font encoding OML on input line 566.
LaTeX Font Info:    Redeclaring font encoding OMS on input line 567.
\macc@depth=\count95
\c@MaxMatrixCols=\count96
\dotsspace@=\muskip10
\c@parentequation=\count97
\dspbrk@lvl=\count98
\tag@help=\toks20
\row@=\count99
\column@=\count100
\maxfields@=\count101
\andhelp@=\toks21
\eqnshift@=\dimen114
\alignsep@=\dimen115
\tagshift@=\dimen116
\tagwidth@=\dimen117
\totwidth@=\dimen118
\lineht@=\dimen119
\@envbody=\toks22
\multlinegap=\skip44
\multlinetaggap=\skip45
\mathdisplay@stack=\toks23
LaTeX Info: Redefining \[ on input line 2665.
LaTeX Info: Redefining \] on input line 2666.
) (C:\MiKTeX\tex\latex\float\float.sty
Package: float 2001/11/08 v1.3d Float enhancements (AL)
\c@float@
  • Is that the complete log? It ends a bit early. – Martin Schröder Sep 29 '15 at 18:16
  • Welcome to TeX.SX! You can have a look at our starter guide to familiarize yourself further with our format. – Martin Schröder Sep 29 '15 at 18:16
  • I've seen reports of a few problems like this on Windows 10. If you do not find another solution, consider installing Ubuntu in a virtual box, or dual booting (much easier to do than it sounds). Hopefully someone is able to figure out the problem though. – scottkosty Sep 29 '15 at 23:35
  • Does the error occur when you export or when you view? Are you clicking on the eyes? How are you doing the "export"? – scottkosty Sep 30 '15 at 2:16
  • If you are clicking on view, I would recommend installing SumatraPDF and using that as your PDF viewer instead of Acrobat. It has solved many problems like this. – scottkosty Sep 30 '15 at 2:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.