I am having this problem with elsarticle. When I compile the file the doi does not appear in the bibliography entries.

\documentclass[review, authoryear]{elsarticle}
\usepackage{lineno, hyperref, chngcntr, array, booktabs, enumitem, multirow, tabu, subcaption, nicefrac}
\usepackage{amsfonts, amsmath, amsthm, amssymb, cleveref, thmtools, thm-restate, lmodern, natbib}
\usepackage{wrapfig, graphicx, framed, ragged2e, mathtools, epsfig, adjustbox, parskip, doi}

author  = "Fernando Bernstein and Awi Federgruen",
title   = "Decentralized Supply Chains with Competing Retailers Under Demand Uncertainty",
journal = "Management Science",
volume  = "51",
number  = "1",
pages   = "18--29",
year    =  "2005",
doi     = "10.1287/mnsc.1040.0218"

\begin{frontmatter}\title{Some Title}\end{frontmatter}

I compile it with TexWorks using the option pdfLaTeX+MakeIndex+BibTex or the option PdfLaTeX/ then bibtex/ then 2 times PdfLaTeX. Everything else works as it should. The problem appears when I use the option


If I ommit it it works fine, but then the citations are numbered (as they should) which is not what I want.

Can anyone please explain to me what is wrong with my code and fix this. Thanks.

  • Not solving your problem, but because you use DOIs I wanted to point out that there is shortdoi.org - can be helpful for dois which span several lines, include cryptic characters, and show all sorts of additional problems (and typewriting by the reader (if printed and not electronically/copy&paste) to get there is also a nightmare). – Stephen Sep 29 '15 at 10:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.