1

I'm working on a beamer poster and would like my figure labels to be both bold font and colored. I'm using the command \captionsetup[figure]{labelformat=simple, labelsep=period, labelfont=bf} to configure the caption, which gives me the bold font, but sets the color back to black. Anyone know how to get both?

Edit

I was able to get the desired effect by placing the following lines in the header:

\usepackage{caption}
\DeclareCaptionLabelFormat{mycaption}{\usebeamercolor[fg]{caption name}#1 #2. }
\captionsetup[figure]{labelformat=mycaption, labelsep=none, labelfont=bf}
3

No need to use the caption package for this; use

\setbeamerfont{caption name}{series=\bfseries}
\setbeamertemplate{caption label separator}[period]

A complete example:

\documentclass{beamer}
\usepackage{beamerposter}

\setbeamerfont{caption name}{series=\bfseries}
\setbeamertemplate{caption label separator}[period]

\begin{document}

\begin{frame}
\begin{figure}
\caption{test}
\end{figure}
\end{frame}

\end{document}

enter image description here

If you want to use the caption package for this (make sure your caption package is updated):

\documentclass{beamer}
\usepackage{beamerposter}
\usepackage{caption}

\DeclareCaptionLabelFormat{mycaption}{\usebeamercolor[fg]{caption name}#1#2}
\captionsetup[figure]{labelformat=mycaption, labelsep=period, labelfont=bf}

\begin{document}

\begin{frame}
\begin{figure}
\caption{test}
\end{figure}
\end{frame}

\end{document}
7
  • Thanks! but I'm also being asked to change the colon to a period, for formatting reasons. Is there a way to do that without the caption package? It seems like using caption interferes with the settings from beamer.
    – MRule
    Sep 29 '15 at 16:31
  • Oh wait... that command is also making the caption itself bold. That's not what I need. I just want the part that says "Figure. 1" to be bold.
    – MRule
    Sep 29 '15 at 16:35
  • @MRule My bad. Please see my updated answer. Sep 29 '15 at 16:41
  • @MRule I also took care of using a period as caption separator. Sep 29 '15 at 16:46
  • Hi Gonzalo, I really appreciate your help. For some reason, it isn't working. It's probably interacting with other customizations that I'm using. I'll prepare a minimal example to reproduce the effect later -- have to go to a meeting now but will be back in a few hours.
    – MRule
    Sep 29 '15 at 16:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.