6

After updating my Mac to El Capitan my Latex was unable to build any new documents. I tried this method however I was unable to fix the issue. So I deleted Latex off my Mac using AppCleaner and downloaded mactex-20150613 from tug.org/mactex/

Now I fail to even install Latex on my computer using the downloaded package installer. Error Message: "The installation failed. The installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance."

Error message

ALso texlive seems to be there in /usr/local. In texlive: 2014, texmf-local (2 folders)

  • 2
    Welcome! What exactly did you delete? Since LaTeX is not an application in Mac OS X's sense, you cannot have deleted LaTeX.app as there is no such thing. AppCleaner is... It is not wise to use these kinds of utilities unless you understand what needs to be done without using them and you are sure that they are going to do exactly that. Did you check the integrity of the download? Maybe it got corrupted? Right now, we don't really know what you did or what happened, I don't think. (But I don't have a recent Mac to be sure.) – cfr Oct 3 '15 at 2:44
  • I don't know what you did with AppCleaner, but let me ask you one question; does /usr/local exist on your machine? If not, you have possibly deleted that directory and even root user is prevented from making new directories under /usr due to the El Capitan's new feature called System Integrity Protection. This might help you disable SIP. – Merzong Oct 3 '15 at 5:10
  • I'm not sure how to check if /usr/local exists. Also tried sudo nvram boot-args="rootless=0 kext-dev-mode=1" based on this method but the computer restored itself back to previous state of disabling it. – user927584 Oct 3 '15 at 5:36
  • I don't think the downloaded file is corrupted but will try again soon. It is probable that AppCleaner didn't delete all the files as package isntaller is about 2.5G and the software deleted about 1G of file I think. – user927584 Oct 3 '15 at 5:43
  • Run ls /usr in terminal. Then, you can see a list of what is in /usr. – Merzong Oct 3 '15 at 13:37
8

I experienced same/similar problem and initially (erroneously) put it down to the OS X El Capitan change to root.

Comments above on corrupted downloads reminded me that the MacTeX site strongly recommended download with Safari. A warning I ignored at my peril, because downloads on OS X via Chrome produced files with wrong checksums! Proof below...

$ md5 mactex-20150613.pkg 
MD5 (mactex-20150613.pkg) = 6aa62533c5aa0bc3d25b166cd67741fb

Whereas the stated package checksum for the MacTeX package [14 June 2015] should be

= bf579a512d31253d828591fdb3644dca

Finally, a version downloaded via Safari yielded the following...

$ md5 mactex-20150613.pkg 
MD5 (mactex-20150613.pkg) = bf579a512d31253d828591fdb3644dca

Lesson learned "do do do run the MD5 file checksum"

3

I had the same problem. I solved it by uninstalling MacTeX manually following the instructions on: https://tug.org/mactex/uninstalling.html

  • 3
    ...and then re-installing it? – Werner Oct 5 '15 at 16:35
  • Yes, correct. After I followed the instructions above, I could re-install with no problems. – Azure Oct 5 '15 at 17:09
  • 2
    My suggestion would be to make your post self-contained. So, rather than pointing to an external site for a solution technique, include the relevant details within your answer as an edit, while still providing the original source link. You might find this is duplicating the target information, but it avoids users who land here to jump somewhere else for the information they need. – Werner Oct 5 '15 at 17:17
  • Did you just delete TeX or any other files such as GUI Applications, TeX Distribution Data Structure and Ghostscript? I deleted the TeX and it still doesn't work – user927584 Oct 9 '15 at 10:31
0

I had the same problem (only other packages). I checked the md5 and the hash corresponded with the hash noticed on the sites where I downloaded the packages.

So after I got the error screen I tried rerunning it, no result. But when I rebooted my computer everything seemed to be fine. I installed Java and Python and they both worked.

So my best guess is that the installer just can't reboot your computer anymore. But when you do it manually everything seems to be fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.