3

I just did a new TeX Live install on another machine, but my project doesn't compile:

(/usr/local/texlive/2015/texmf-dist/tex/latex/ms/everysel.sty))
! No room for a new \skip .
\ch@ck ...\else \errmessage {No room for a new #3}
                                                  \fi 
l.3446 ...r\newseries\expandafter{\default@series}

I tried

\usepackage{etex}
\reserveinserts{28}

as second and third line of my file, but it didn't work, so I commented it back out.

then

? h
This error message was generated by an \errmessage
command, so I can't give any explicit help.
Pretend that you're Hercule Poirot: Examine all clues,
and deduce the truth by order and method.

I guess I could need some help with that...

Typing E at the error prompt gets me into eledmac.sty.

Edit: I have minimised my example further.

\documentclass{memoir}
\usepackage[noreledmac]{eledmac}
\begin{document}
something
\end{document}
  • Are you running a loop that reserves new skip registers? – user31729 Oct 3 '15 at 9:53
  • @ChristianHupfer Not that I'm aware of that. – muk.li Oct 3 '15 at 9:54
  • @ChristianHupfer How would I detect that? The same project builds fine on other machines with TeX Live installs a few weeks old. – muk.li Oct 3 '15 at 10:00
  • Each new skip is reported to the .log file in the form .... = \skipXY where XY is an integer number – user31729 Oct 3 '15 at 10:03
  • @ChristianHupfer I grepped my logfile for skips, it reserves 299 of them for apparently different things and then fails at the 300th of them. – muk.li Oct 3 '15 at 10:19
5

You should not ever need to load etex.sty these days, but if you do load it is best to load it first.

(r)eledmac have been updated to use the latex extended allocation scheme so if you get the latest

\ProvidesPackage{eledmac}[2015/10/05 v1.24.9 LaTeX port of EDMAC]%

version of eledmac then you can use

\documentclass{memoir}
\usepackage[noreledmac]{eledmac}
\begin{document}
something
\end{document}

With older versions of eledmac you need to load etex.sty early and reserve more inserts when using current latex:

\RequirePackage{etex}
\reserveinserts{40}
\documentclass{memoir}
\usepackage[noreledmac]{eledmac}
\begin{document}
something
\end{document}
  • see my comment, Thanks David for your help. – Maïeul Oct 5 '15 at 19:33
  • @Maïeul I think I'm confused over the relationship between elemac and reledmac, but no matter:-) – David Carlisle Oct 5 '15 at 22:11
  • reledmac is just the version 2.x of eledmac (which was the version 1.x of ledmac). I do not maintain anymore eledmac, except for minor points for compatibility with new release of LaTeX. – Maïeul Oct 6 '15 at 11:55
4

What David said is partially true. The last version of eledmac has been updated.

However, a better way is to use the optimization options of (r)eledmac to disable series you do not need.

For example if you need only series A and you do not need familiar notes, do:

\usepackage[noreledmac,series={A},nofamiliar]{eledmac}

read § 11 of the handbook.

2

David Carlisle found a way to solve this problem directly in (r)eledmac code. The version 1.24.9, just send on the CTAN, solve this issue, without needed to

\RequirePackage{etex}
\reserveinserts{40}

before the \documentclass

The version 2.2.1 fixes for reledmac.

What I have said about option like

\usepackage[series={A},nofamiliar]{eledmac}

is still available, as it will provdie a faster version of (r)eledmac.

  • thanks I just checked ctan version and confirm this works, I'll update my answer. I guess it will be in texlive tomorrow. – David Carlisle Oct 6 '15 at 13:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.