5

I use both Win7 and Win8.1 on 2 different machines. This morning I upadated the MiKTeX packages in admin. Since, I have trouble compiling documents that used to be compilable as late as yesterday. On Win8.1, the error message states: "This application failed to start because it could not find or load Qt platform plugin"windows". The recommandation message that follows is: reinstalling the application may fix the problem. Which application is unclear.

On win7 (with all packages and fixes updated), the error message is: "The program can't start because QtGui4.dll is missing from your computer. Try reinstalling the program to fix this problem." Again, it is not clear which application is required. I am guessing that it could be QuickTime, but as I never used this software, I unistalled it about 2 or 3 years ago (maybe even before).

I tried different documents but some do compile and others won't. They are all documents that I have compiled before. Unhappily a MWE works on my Win7 PC but not on the Win8.1

How should I update this QT package? Thank you Regards.

  • I tried uninstalling the miktex-qt5-bin package (packaged on 2015-06-24). Without it, got the missing QtGui4.dll message. And same after reinstalling it (and refreshing the fndb). Any other idea? – Xavier_B Oct 3 '15 at 10:36
  • Error message after loading ts1enc.def: "This application failed to start because it could not find or load the Qt platform plugin "windows". I reckon it is a pdflatex induced error, hence it must come from recent updates to the miktex pdflatex engine. Still no solution. – Xavier_B Oct 5 '15 at 7:55
  • I accuse the updates miktex-bin-2.9 dated 30-Sep-15 and possibly the l3kernel and l3packages from 29-Sep-15 from being at the origin of this Qt platform problem. They are the last to have been updated and compilation by pdflatex stopped working from that date. Could those who do the work on updating those essential pieces of MiKTeX see what is happening? – Xavier_B Oct 5 '15 at 12:02
  • I had this exact problem a few days ago after updating (even down to removing the qt5-bin package), found your post and bookmarked it to hopefully come back for a solution. I have now just done an a MikTeX Admin Update and all appears to be well. I am too inexperienced to suggest what the exact cause of the problem was. – AndrewTom Oct 5 '15 at 19:30
  • Unless miktex/latex/texworks searches for and updates stuff automatically, this problem is due to magic and not updates. I have the same problem and have done no updates, all I've done that could conceivably influence any of this are the windows updates (I'm using win7). Miktex ran just fine as late as oct 5, but today there was a problem. Not on my other computer though. Magic! – Erik Vesterlund Oct 9 '15 at 11:06
4

Qt, in this case, is the Qt library used by MikTeX (https://www.qt.io). I can't reproduce your Windows 7 error, however, I know how to fix the Windows 8 one.

You can fix this error by copying the file qwindows.dll from <install folder>/miktex/bin/platforms/ to <your user home>/AppData/Roaming/MikTex/<version number>/miktex/bin/platforms/.

You might have to create the platforms folder.

  • This "fix" didn't work for me on windows 7. I am now really regretting updating Miktex. Doing an uninstall/reinstall hasn't helped either. – Bull Nov 13 '15 at 10:50
  • I am using Windows 8, and I followed the recommendation by @xxmicloxx. However, it does not solve my problem - I keep getting "The program can't start because QtGui4.dll is missing from your computer. Try reinstalling the program to fix this problem." – Beck Dec 7 '15 at 13:08
4

This error message about QtGui4.dll started happening for me this evening after I selectively updated some MiKTeX packages.

The solution that worked for me was to update all packages starting with miktex, and I had to do this twice: once with "Update" and once with "Update (Admin)" that are found under MiKTeX's Start Menu entries.

1

I had the very same error message yesterday after updating some packages. I reinstalled both Texmaker and MikTex 2.9, made all updates of packages and still the same error. After a day of struggling with the MikTex options I switched install missing packages from "ask me first" to "yes". And it started working. Somehow it seems that the update manager was blocked before it could ask me. I would be grateful if someone could explain why this happened.

  • There is still the problem with Qt on Windows. The point is that the problem occurs only when miktex tries to popup the window about installing a missing package, so either swtichting to "yes" or "no" avoids creating the window. I wonder how it get's which package needs to be installed. – user87690 Oct 17 '17 at 10:56
0

Yesterday, I have updated to TeXstudio 2.11.2 on Win7 and I have received an error saying that 'Qt platform plugin was not found/loaded' while attempting to run the application. I believe this is a MikTex associated error, therefore I decided to replay here.

I did the following in order to fix the error:

  1. I uninstalled the TeXstudio and MikTex by using Revo Uninstaller to ensure that all dependencies were deleted.

  2. I used Ccleaner to clean up the Windows 7 registers.

  3. I installed the MikTex and ran (as administrator) the update tool.
  4. I compared the dll libraries in MikTex folder with ones installed on my second computer. It seems that all are in place, with one exception, that those on my second PC work.

Thank you very much for your help!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.