15

Texstudio doesn't work for me anymore after updating to Mac OS X 10.11 El Capitan. I have the latest version of TexStudio installed (2.10.2). As pointed out by Herbert Schulz, this is due to a change in the places OS X allows files to be saved. When I started TexStudio, I received a message "PDFLatex could not be launched". In the settings, I had to change the folder of the compiler from user/texbin/ to /Library/Tex/texbin, as shown in the screenshot below:

Changed setting in TexStudio

Can anybody tell me if I have to make further changes in order to make TexStudio fully working (bibliography and the like), and if yes, which?

I hope TexStudio are very soon going to release an update (there is an issue for this on their issue queue.

Thank you for your help. This is my first post here, so please apologize any imprecisions.

  • Welcome to TeX.SX! If you have installed MacTeX 2015, what you have to do is changing all /usr/texbin strings into /Library/TeX/texbin – egreg Oct 3 '15 at 14:49
  • 1
    @egreg On my MacBook the symbolic link /Library/TeX/texbin did not exist after the upgrade. One should either create it or re-install MacTeX. – Siminore Oct 3 '15 at 14:53
  • Thanks @Siminore, this fixed it for me. Example command for creating such a symlink: sudo ln -s /usr/local/texlive/2012/bin/x86_64-darwin/ /Library/TeX/texbin – jsaven May 28 '17 at 0:04
10

I found this; change all the folder directories accordingly and it will work for you. It did for me:

op-configuration-screenshot


Updated
The previous screenshot has an error, in Makeglossaries, the /usr/texbin/, must be changed to /Library/Tex/texbin/, so that it properly works.
This is how your configuration for OS X 10.11 should look:
corrected-makeglossaries-screenshot

  • Welcome to TeX.SX! You can have a look at our starter guide to familiarize yourself further with our format. – Martin Schröder Oct 4 '15 at 14:26
  • Thank you for the advice! The path in Makeglassaries and other "less visible" paths should probably also be changed though accordingly. Waiting for the update! – Cyril Oct 4 '15 at 16:03
3

The solutions above didn't work for me unfortunately. But I did some mixture of those and it seems to work.

I have a early 2013 MacBook Pro and I have set MacTex 2015 up after upgrading the OS to El Kapitein.

Then I used these settings for TeXstudio (in Preferences from the global TeXstudio menu):

enter image description here

The important thing is, I set the Commands ($PATH) option also to /Library/TeX/texbin as shown below (the very last line in the SS):

enter image description here

It worked for me. I am very happy that I can use TeXstudio again. I hope this would be helpful for you as well.

2

In "TeXstudio->Preferences":

From the left pane, in the "Build" section, change the "Commands ($PATH)" to:

/Library/TeX/texbin

in the "Command" section from the left pane, add the following in front of "PdfLaTex":

"/Library/TeX/texbin/pdflatex" -synctex=1 -interaction=nonstopmode %.tex

Similarly, if you need to use Xelatex, add the following in front of "XeLaTex":

xelatex -interaction=nonstopmode %.tex

NOTE: These changes are required because in El Capitan, the location /usr is reserved for Apple, and even users with root access are not allowed to write to that location.

2

I tried this solution of changing in the TexStudio Preferences from "/usr/texbin" into "/Library/Tex/texbin" but it didn't work.

I'm using a Macbook Pro early 2015 with 10.11 Mac OS. I found another path for the requested libraries and it works for me using this:

Another way to find a way

I found these files in "/Library/Tex/Distributions/Programs/texbin". Once you arrive to that folder, only choose the corresponding file for everyone.

Sorry for the bad edition.

1

my configeration, Mac Pro 2012 & Ei Capitan

My configuration is a bit different, but this works for my TeXstudio. Hope this is helpful. :-)

0

I had to do a modified version of the above answer, with the difference shown in the blue rectangle. (El Capitan 10.11.13; MacBook Pro (Retina, 15-inch, Mid 2015))

My config

0

The solution is fully explained in [this pdf] (https://tug.org/mactex/UpdatingForElCapitan.pdf), section 8, "Don’t have MacTEX-2015+?"

Run the following commands

sudo ln -fhs Distributions/.DefaultTeX/Contents/Programs/texbin /Library/TeX/texbin
echo "/Library/TeX/texbin" >~/Desktop/TeX
sudo cp ~/Desktop/TeX /etc/paths.d/TeX
echo "/Library/TeX/Distributions/.DefaultTeX/Contents/Man" >~/Desktop/TeX
sudo cp ~/Desktop/TeX /etc/manpaths.d/TeX

which essentially create the link on Library for other programs to use it.

protected by Community Nov 10 '15 at 15:35

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.