15

This question already has an answer here:

After having updated to Mac OS X El Capitan (10.11), I'm no more able to compile using either TexMaker or TexShop. This is the message I get from TexShop

"/usr/texbin/pdflatex does not exist. TeXShop is a front end for TeX, but you also need a TeX distribution. Perhaps such a distribution was not installed or was removed during a system upgrade. If so, go to http://www.tug.org/mactex/ and follow the instructions to (re)install MacTeX. A less likely possibility is that a tool path is incorrectly configured in TeXShop preferences. This can happen if you are using the macports or fink distributions."

I tried to change the path in Preferences-Engine, as many suggested. Yet, it doesn't work either. Any help?

marked as duplicate by Martin Schröder, Mensch, egreg errors Oct 4 '15 at 19:39

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 3
    You may have to reconfigure the folder structure referenced by TeXmaker. Related: Reconfiguring TexStudio after upgrade to OS X El Capitan – Werner Oct 4 '15 at 15:35
  • 1
    You must update Texshop. – jpayansomet Oct 4 '15 at 15:38
  • 1
    Welcome! See this page. – cfr Oct 4 '15 at 16:22
  • @MartinSchröder: I fail to see how this is a duplicate in the sense that this is asking about TeXShop, and the "existing answer" tells what to do for TeXStudio. The answers in this question and the "existing answer" do not help a TeXShop user at all. The GUIs are completely different. – jvriesem Jan 9 '16 at 20:08
14

I just solved it. You just need to change the path of the files for the command according to the new organization in El Captain. I posted a screenshot. It works for me!

Hope this helps!

enter image description here

  • Welcome to TeX.SX! You can have a look at our starter guide to familiarize yourself further with our format. – Martin Schröder Oct 4 '15 at 19:09
  • Thank you! that's exactly right! In TexShop I had to do the same too. Add /usr/local/texlive/2014/bin/universal-darwin/ to the path settings in the Engine tab. – iamaziz Oct 10 '15 at 18:47
  • I changed my settings according to the post after upgrading to El Capitan. I can compile .tex now, but cannot use R Sweave. Can someone help? Thanks very much! I get this message in TexMaker: Error : could not start the command : R CMD Sweave "text".Rnw... – Leshui Dec 17 '15 at 2:52

Not the answer you're looking for? Browse other questions tagged or ask your own question.