9

This question already has an answer here:

I get this error when clicking "typeset" on TeXShop:

"/usr/texbin/pdflatex does not exist. TeXShop is a front end for TeX, but you also need a TeX distribution. Perhaps such a distribution was not installed or was removed during a system upgrade. If so, go to http://www.tug.org/mactex/ and follow the instructions to (re)install MacTeX. A less likely possibility is that a tool path is incorrectly configured in TeXShop preferences. This can happen if you are using the macports or fink distributions."

How do I fix this issue? (I apologize if the tag below is incorrect.)

marked as duplicate by Johannes_B, OSjerick, user13907, Martin Schröder, moewe Oct 23 '15 at 13:38

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • ok thanks -- I tried "check for updates" and this errors, so I can't update it through teashop. – Moz Oct 4 '15 at 17:16
  • I also changed the path to /Library/TeX/texbin and this doesn't fix the error – Moz Oct 4 '15 at 17:18
  • If I download mactex 2015 (2.5 GB), will the old one be written over? -- I don't want 2 2.5 GB files. – Moz Oct 4 '15 at 17:23
  • 3
    Please refer to tug.org/mactex/elcapitan.html for changes needed after updating to El Capitan. – moewe Oct 4 '15 at 17:31
  • 3
    This problem seems to be cropping up a lot. Might be time to get a CW question and answer going.... – jon Oct 4 '15 at 17:46
3

Go to Terminal type which pdftex

You will get a result of the form /something_1/something_2/.../something_n/pdftex

Copy /something_1/something_2/.../something_n/

Go to TeXShop>Preferences>Engine in the first box of that says path settings Paste.

That is all. This worked for me. This way you are changing the path setting manually.

  • 1
    This did not work for me. Terminal returned nothing at all when I typed which pdftex (or which pdflatex). I am struggling to find an answer anywhere on the web that works. – Steve Kass Aug 6 '16 at 21:54
  • This also does not work. Should not be accepted as anwer – invictus Nov 20 '16 at 18:00

Not the answer you're looking for? Browse other questions tagged or ask your own question.