2

This question is similar to his question.

I made a Table of Contents which doesn't reference the Table of Contents as the first entry.

\documentclass[12pt,a4paper]{report}
\usepackage[a4paper,margin=6mm, bottom=14mm]{geometry}
\usepackage{amsmath}
.
.
.

\title{COMPUTATIONAL METHODS FOR THE RIEMANN ZETA FUNCTION}
\author{Axion004}
.
.
.
\begin{document}
\maketitle
\pagestyle{empty}
\pagenumbering{gobble} %????
\tableofcontents
\clearpage
\pagestyle{axionstyle}
\pagenumbering{arabic}%
\section*{Summary}
.
.
.
\end{document}

The PDF looks like

enter image description here

How can you adjust the above screen shot so that "Table of Contents" appears as an entry above Summary? That is, I want to include the ToC as part of the ToC.

1
  • Use \usepackage{tocbibind} -- your \section*{Summary} won't appear in the ToC however (at least not with this code) And please don't use ... in the document preamble -- it means typesettings dots which is isn't possible
    – user31729
    Oct 5, 2015 at 17:39

2 Answers 2

3

The tocbibind package is the easiest way to achieve this. It has multiple options to prevent the LoF, LoT or bib in the ToC, if needed.

\documentclass[12pt,a4paper]{report}
\usepackage[a4paper,margin=6mm, bottom=14mm]{geometry}
\usepackage{amsmath}
\usepackage{tocbibind}

\title{COMPUTATIONAL METHODS FOR THE RIEMANN ZETA FUNCTION}
\author{Axion004}
\begin{document}
\maketitle
\pagestyle{empty}
\pagenumbering{gobble} %????
\tableofcontents
\clearpage
%\pagestyle{axionstyle}
\pagenumbering{arabic}%
\section*{Summary}
\chapter{Some chapter}
\end{document}

enter image description here

1

With the memoir class (which is a superset of the book,reportandarticle` classes it is as simple as

\documentclass[...]{memoir}
...
\begin{document}
\tableofcontents

Using \tableofcontents* instead gives the same result as \tableofcontents does in book/report classes

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .