2

I am attempting to input Syriac into XeLaTeX but is not loading correctly. I am using MiKTeX on windows below is my example:

\documentclass{article}

\usepackage{xesyriac}
\begin{document}

Hello World

\end{document}

But when I attempt to build the file, I receive an undefined control sequence error concerning a package internal command, which brings me to the line marked by an arrow in xesyriac.sty

    \notbool{xsy@nodefaultfonts}{%
\setmainsyriacfont{Estrangelo Edessa}
\newsyriacfont\estrfont{Estrangelo Edessa}
\newsyriacfont\sertofont{Serto Jerusalem}
\newsyriacfont\madnhafont{East Syriac Adiabene}}{%

->   \AtBeginDocument{\ifdef{\syriacfont}{}{\PackageError{XeSyriac}{A main Syriac font is not defined}{Use \protect\setsyriacfont\space in the preamble to define a main Syriac font.}}}}

I posted the lines above because they seem relevant, I have all three fonts installed on my windows machine, but it seems XeLaTeX cannot find them.

1 Answer 1

2

To save others time, xesyriac comes from users.ox.ac.uk/~wolf2305/xesyriac.html, and the fonts referred to in the question are available at www.bethmardutho.org/index.php/resources/fonts.html. The package requires xecolour, so download that from CTAN, because TeX Live has xecolor, not xecolour.

Now you will probably get this error:

ERROR: fontspec error: "font-not-found"

--- TeX said ---
!
! The font "Aramaic Numbers" cannot be found.
!
! See the fontspec documentation for further information.
!
! For immediate help type H <return>.
!...............................................

l.243 ...ace\ArmNum[FakeBold=1.3]{Aramaic Numbers}

kpathsea:make_tex: Invalid fontname `Aramaic Numbers', contains ' '

l.243 ...ace\ArmNum[FakeBold=1.3]{Aramaic Numbers}

Googling for a font called “Aramaic Numbers” led nowhere.

However, I was able to compile a document by editing xesyriac.sty, changing line 243 from “\newfontface\ArmNum[FakeBold=1.3]{Aramaic Numbers}” to “\newfontface\ArmNum{Estrangelo Edessa}”.

\documentclass[12pt,a5paper]{book}
\usepackage[insyriac=true,loadfonts,numerals=alphabetic]{xesyriac}
\begin{document}
\huge
ܐܣܛܪܢܓܠܐ
\end{document}

output

I was able to use the western, eastern, and alphabetic options for numerals, but not the aramaic option.

It looks like time to contact the author of xesyriac. Meanwhile, if you edit the package for your own purposes, it’s best to rename it (e.g., call it mysyriac.sty, and make line 42 read, “\ProvidesPackage{mysyriac}%”).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .