1

I have just updated my Mac to El Capitan. I also updated my MacTex to the newest MacTex 2015 by downloading and installing it. I also updated my TexStudio to TeXstudio 2.10.2 (the latest version). Now, when I try to compile my previously well-working .tex files I get this:

Error: Could not start the command: /usr/texbin/pdflatex -synctex=1 -interaction=nonstopmode

On TexShop which comes as part of MacTex package my files open and compile just fine. Please, I really am used to TexStudio, can anyone tell me what, how should I configure my TexStudio so it can work with MacTex, El Capitan...?

  • 1
    Please look at all the other El Capitan questions currently on the site. Apple have disallowed anyone but apple to write on /usr so /usr/texbin will not work. – daleif Oct 6 '15 at 5:44
1

Please refer to Herbert Schulz's instruction or this question "Reconfiguring TexStudio after upgrade to OS X El Capitan" about how to modify TeXstudio's command configuration after upgrading to OS X El Capitan.

1

There is a change in the way OS X El Capitan allows apps to access system folders, all you have to do is open Settings and change every instance of /usr/texbin/ to Library/TeX/texbin/. This is under the Commands tab.

Edit: Clarified with screenshot

Screenshot of TexStudio

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.