4

I am getting the impression that discretionary hyphens don't work at all in paragraphed footnotes, not really depending on which package is used for the footnotes. I've painfully experienced it with manyfoot and eledmac, being many times forced to use \discretionary to get proper hyphenation. I was able to reproduce a similar problem with bigfoot, the following now is an example with footmisc, which I understand to be the most basic way to make paragraphed footnotes (correct me if I'm wrong.):

\documentclass[a4paper]{article}
\usepackage{fontspec}
\usepackage[para]{footmisc}
\begin{document}
\footnote{XXXXXXXXXXXXXX just a few normal words to fill up the line
  up to my word hy\-phe\-na\-te\-me}
\end{document}

This example will print hy\-phe\-na\-te\-me on the second line of the footnote. Gradually removing the Xes eventually my word will be printed fully at the end of the first footnote line, but never be hyphenated.

I am using xelatex. I need the fontspec package to display letters with diacritics. For this example, in which I've not used any diacritics, when I comment out fontspec, the word gets hyphenated. Also if I don't use the [para] option of footmisc, or comment out footmisc altogether, the word gets hyphenated.

As I mentioned, I also have many real life examples with other packages.

  • 1
    I do not use XeLaTeX, but if you add \usepackage{microtype} and compile it with LuaLaTeX it works as you want ... Is LuaLaTeX an option for you? – Mensch Oct 6 '15 at 0:05
  • 1
    Note that the following will hyphenate: \footnote{XXXXXXXXXXXXXX just a few normal words to fill up the line up to my word hy\-phe\-na\-te\-me as}. – jon Oct 6 '15 at 0:46
  • 1
    Hmm, you're right. I compiled last with lualatex and didn't notice the difference. However, this seems to work: \hyphenation{hy-phe-na-te-me} (goes in the preamble; spell the word normally in the text). – jon Oct 6 '15 at 1:43
  • 2
    Yes, but \hyphenation{} is not a workaround: it is the preferred method for globally setting the correct hyphenation points for words TeX fails to do correctly. According to TeX By Topic, the command defines 'hyphenation exceptions for the current value of \language'. Using \- is ad hoc and therefore discouraged. – jon Oct 6 '15 at 2:07
  • 1
    looks like a xetex feature, probably worth pinging their support list. – David Carlisle Oct 6 '15 at 9:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.