3

I just bought a new computer. So I instal Miktek and Texmaker on it and wanted to change something on my resume. Unfortunately I have the following errors :

enter image description here enter image description here

I searched for solution but nothing worked.

p.s. it works perfectly on my old computer

A minimal example producing the error is

\documentclass{article}

\usepackage{texlogos}

\begin{document}
Test. 
\end{document}

The same error occurs on texlive 2015.

  • Welcome to TeX - LaTeX! Can you provide more details of your document? One guess would be that you are using moderncv. In which case you should make sure that Miktex has installed all necessary dependencies for this package. – Andrew Swann Oct 7 '15 at 7:06
  • Yes, I'm using moderncv. I redownload the moderncv package and add manually all the files in C:\Program Files\MiKTeX 2.9\tex\latex\moderncv but nothing change. The code in tex.stackexchange.com/questions/128415/… work fine. – misterpoulpes Oct 7 '15 at 8:11
  • You say the other code works fine. Then you should show us your code, or prefarably a cut down minimal working example (MWE), so we can help work out what the problem is. By the way, have you tried installing moderncv via miktex's package manager system? See tex.stackexchange.com/a/55473/15925 and tex.stackexchange.com/q/108447/15925. Fonts don't reside in the style directory. – Andrew Swann Oct 7 '15 at 8:56
  • Do you have any idea how to solve it ? – misterpoulpes Oct 7 '15 at 18:58
  • I can reproduce the problem with a standard article document containing just the texlogos package. The strange thing is logo8 loads fine but logosl8 does not. Both are on my system and the .pfb files can be found via kpsewhich. We need a font expert. Or you could try the CTAN list. – Andrew Swann Oct 8 '15 at 17:13
3

The “Logo” fonts distribution underwent a restructuring between TeX Live 2013 and 2014 and the same happened to MiKTeX.

The Metafont sources that are listed in CTAN under <CTAN>/fonts/mflogo/mf were almost all copies of those in <CTAN>/sys­tems/knuth/dist/lib/ and are now packaged in TeX Live as knuth-lib.

Unfortunately, one of the font sources is missing and it is logosl8.mf (for which another package provides the PFB version). The contents of the file is very short

% 8-point slanted METAFONT logo
% [ heavily borrowed from D. E. Knuth ]

% Copyright (C) 1995--1999 Ulrik Vieth
%
% This program is free software; you can redistribute it and/or
% modify it under the terms of the LaTeX Project Public License
% as described in lppl.txt in the base LaTeX distribution; either
% version 1 of the License, or (at your option) any later version.

slant := 1/4;
input logo8

A bug report should be filed to the TeX Live maintainers (MiKTeX should follow) so they do something about the problem. In the meantime, having a logosl8.mf in the working directory should suffice to get out of the dilemma.

On the other hand, I'd be wary of loading texlogos, which is undocumented and wrongly written as it uses \font directly.

Update

As of October 15, 2015, the distribution of the logo fonts has been updated and the hack of keeping logosl8.mf along with the file is not needed any more (on TeX Live 2015 and later).

| improve this answer | |
  • I'm sorry but I placed the logosl8.mf in the working directory but nothing changed for me. – misterpoulpes Oct 10 '15 at 11:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.