5

I reinstalled MacTeX-2015 yesterday to deal with some problems related to my recent "upgrade" to OS X 10.11 "El Capitan". Since reinstalling the TeXLive utility is giving me the message:

Repository URL has a newer TeXLive Version. Your TeX Live version is 0, but your default repository URL appears to be for TeX Live 2015. You need to manually upgrade to a newer version of TeX Live, as there will be no further updates for your version.

Clicking the upgrade button simply takes me to the MacTeX website. I would think that a fresh install of the latest version would remedy this, but that's apparently false since I have already done that. My current TeXLive version is 1.21.

Update: I manually deleted all my installed distributions in /usr/local/texlive (leaving only /usr/local/texlive/texmf-local) and then reinstalled. That replaced the directory /usr/local/texlive/2015, but has not resolved the problem.

1
  • Is the message the same if you issue sudo tlmgr update from a terminal?
    – egreg
    Oct 7, 2015 at 14:52

1 Answer 1

7

Solution: Update TeXLive preferences to indicate new location of TeX programs in /Library/TeX/texbin/.

Thanks egreg for setting me on the right path.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .