1

I have a latex document that contains lots of floats, and so I want to place them all at the end of the pdf.

I have done this using:

\usepackage[nomarkers, nolists]{endfloat} 

Above all of my images though, I have the [!] from my

\begin{figure*}[!]

I'm obviously doing something stupid. Could anyone tell me what it is please?


Here is a working example of my problem. Where the plots should be, you can see [htbp]

\documentclass[a4paper,fleqn,usenatbib]{mnras}

\usepackage[T1]{fontenc}
\usepackage{ae,aecompl}

\usepackage{graphicx}   % Including figure files
\usepackage{amsmath}    % Advanced maths commands
\usepackage{amssymb}    % Extra maths symbols


\title[title}

\author[K. T. Smith et al.]{
Keith T. Smith,$^{1}$\thanks{E-mail: mn@ras.org.uk (KTS)}
A. N. Other,$^{2}$
Third Author$^{2,3}$
and Fourth Author$^{3}$
\\
$^{1}$Royal Astronomical Society, Burlington House, Piccadilly, London W1J 0BQ, UK\\
$^{2}$Department, Institution, Street Address, City Postal Code, Country\\
$^{3}$Another Department, Different Institution, Street Address, City Postal Code, Country
}


\date{Accepted XXX. Received YYY; in original form ZZZ}

\pubyear{2015}

\begin{document}
\label{firstpage}
\pagerange{\pageref{firstpage}--\pageref{lastpage}}
\maketitle

\begin{abstract}
This is a simple template for authors to write new MNRAS papers.
The abstract should briefly describe the aims, methods, and main results of the paper.
It should be a single paragraph not more than 250 words (200 words for Letters).
No references should appear in the abstract.
\end{abstract}

\begin{keywords}
keyword1 -- keyword2 -- keyword3
\end{keywords}

\section{Introduction}
Introduction
\section{Observations}
Observations.
\section{Data Analysis}
\label{dataanalysis}
Data analysis
\section{Results}
results
\begin{figure*}[htbp]
\begin{center}
\includegraphics[width=150mm]{plot.png}
\caption{Plot caption}
\label{}
\end{center}
\end{figure*}
\begin{figure*}[htbp]
\begin{center}
\includegraphics[width=150mm]{plot2.png}
\caption{caption2}
\label{}
\end{center}
\end{figure*}

\bsp    % typesetting comment
\label{lastpage}
\end{document}
  • 1
    What mean [!]? Try omit it. – Zarko Oct 8 '15 at 11:59
  • Well, I mean whatever float placement options I have ([!htb] for example) - they appear in the text. – user1551817 Oct 8 '15 at 12:04
  • 1
    I suggest to omit !. Just use [htbp] or nothing. If this not help, than you need to read endfloat documentation. I'm not familiar with this package. – Zarko Oct 8 '15 at 12:09
  • Yeah it still happens without the ! I will read more about endfloat. Thanks. – user1551817 Oct 8 '15 at 12:15
  • Please, provide minimal working example which shows your problem. With it will be easier to help you. – Zarko Oct 8 '15 at 12:17
2

The answer is given in the manual of the document class:

The LaTeX float placement commands [htbp] are intentionally disabled. Layout of figures and tables will be adjusted by the publisher during the production process, so authors should not concern themselves with placement to avoid disappointment and wasted effort.

As the floating environment are redefined to not have an optional argument, [..] is interpreted as normal text, and printed in the document.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.