0

I've had a rough time trying to print a bibliography in a document. I wrote a MWE and found even more issues.

\documentclass{article}
\usepackage[english]{babel}
\usepackage[backend=biber]{biblatex}
\usepackage[autostyle,english=american]{csquotes}

\addbibresource{tb.bib}

\begin{document}
I'd like to cite Masere and friends \cite{masere}, as well as Strogatz \cite{strogatz}.
\printbibliography
\end{document}

And the .bib file contains the following:

@article{masere,
author="J. Masere, D. A. Vasquez, B. F. Edwards, J. W. Wilder, and K. Showalter",
title="Nonaxisymmetric and Axisymmetric Convection in Propagating Reaction-Diffusion Fronts",
journal="J. Phys. Chem.",
volume="98",
number="26",
pages="6505--6508",
year="1994",
doi="http://dx.doi.org/10.1021/j100077a014",
}

@book{strogatz,
title={Nonlinear Dynamics and Chaos},
subtitle={With Applications to Physics, Biology, Chemistry, and Engineering},
author={S. H. Strogatz},
isbn={0-201-54344-3},
series={Studies in Nonlinearity},
year={1994},
publisher={Perseus Books},
}

After using pdflatex test.tex on the command prompt, I get the following:

No file test.bbl.

LaTeX Warning: Citation 'masere' on page 1 undefined on input line 9.


LaTeX Warning: Citation 'strogatz' on page 1 undefined on input line 9.


LaTeX Warning: Empty bibliography on input line 10.

[1{C:/ProgramData/MiKTeX/2.9/pdftex/config/pdftex.map}]
(C:\Users\me\Documents\Sandbox\test.aux)

LaTeX Warning: There were undefined references.


Package biblatex Warning: Please (re)run Biber on the file:
(biblatex)                test
(biblatex)                and rerun LaTeX afterwards.

After that, I used biber test.tex and got:

INFO - This is Biber 2.1
INFO - Logfile is 'test.tex.blg'
ERROR - Cannot find control file 'test.tex.bcf'! - did you pass the "backend=biber" option to BibLaTeX?
INFO - ERRORS: 1

I also found this last ERROR in my original file, and now I really don't know what to do. I just realized that this question is quite long, and I apologize for that. Any help will be appreciated.

1

Check the folder where your tex file is. Pdflatex should have created the file test.bcf in that folder. (At least, this is what happens on my machine.)

Note that biber is looking for test.tex.bcf with two extensions. Maybe you need to run biber test (instead of biber test.tex) instead.

  • As others pointed out, this was the main issue. It's a bit embarassing that the file extension caused me so much trouble, though. There was one more thing: biber didn't like the author entry to have so many commas, which resulted in problems. Thank you very much! – Drarp Oct 8 '15 at 15:26
  • 1
    @Drarp Yes, the name list in your example above is off it should be {J. Masere and D. A. Vasquez and B. F. Edwards and J. W. Wilder and K. Showalter} you must separate two authors by and, commas are there to delimit the parts of a name, not to separate two authors. See also How should I type author names in a bib file?. Biber might be a bit more sensitive to these issues and sometimes throws more prominent warnings than BibTeX does. – moewe Oct 10 '15 at 7:20
0

If you work bit around, this should work fine.

\documentclass{article}
\usepackage[english]{babel}
%\usepackage[backend=biber]{biblatex}
\usepackage[authoryear,numbers,round]{natbib}
\usepackage[autostyle,english=american]{csquotes}


%\addbibresource{test.bib}

\begin{document}
 I'd like to cite Masere and friends \cite{masere}, as well as Strogatz \cite{strogatz}.
\bibliographystyle{plainnat}
\bibliography{test}
%\printbibliography
\end{document}

Just put the name of the .bib file in the same folder or put the path file to the \bibliography and it should work fine.

enter image description here

  • Why was this downvoted? – user31729 Oct 8 '15 at 15:14
  • @ChristianHupfer Maybe, just maybe - I don't know, I didn't vote on this answer - because it is bending the aim of the question a bit by employing natbib instead of biblatex. – moewe Oct 8 '15 at 15:23
  • @ChristianHupfer Probably because it switches to natbib. Still, thanks for providing an alternative, Slavisa. – Drarp Oct 8 '15 at 15:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.