I'm using Zotero to manage and export reference lists. Sometimes text fields contain an accent, circumflex, umlaut etc.

When I used such bib files in LyX (tried the plain and unsrturl styles), I get the following errors:

  • Command \texteuro unavailable in encoding T1 (similar error for OT1; using \usepackage{textcomp} makes the error disappear)
  • Undefined control sequence
  • Package inputenc Error: Keyboard character used is undefined (still appears, even after using \usepackage{textcomp})

Only when I replace accented characters with regular characters the code compiles.


As @MikeRenfro pointed out, the solution from OhadSoft: Zotero – exporting Unicode and LaTeX constructs to BibTex, worked:

  1. Zotero Preferences -> Export -> check Display character encoding option on export.
  2. Whenever you export your database, pick a non-Unicode character encoding such as ISO-8859-1
  • I think that in newest versions of Zotero this solution is not working. Im using 5.0.64 and even that by default you can pick an encoding option when exporting, you cant select ISO-8859-1 nor latin1 anymore. Im stuck with this same problem. – Santiago Capobianco Mar 22 at 14:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.