2

Under Options > Configure TeXstudio > Commands I changed PdfLateX to use the -output-directory=tex option. I checked Show Advanced Options in the bottom right corner and set all additional search paths under Build to the used directory name.

Everything works (I can compile to PDF and preview it in the internal PDF viewer) but I don't know how I should change the External PDF Viewer command so that it opens the PDF from the subdirectory.

3

This worked for me (on Windows 7, note that I use PDFViewer, not Adobe Reader):

External PDF Viewer command (where 'build' is my custom output directory):

"C:\Program Files\Tracker Software\PDF Viewer\PDFXCview.exe" ".\build\?m.pdf"

Notice the quotes around the argument; they are needed if there are any spaces in the file/sub-directory name.

5

I think a more generic solution would be to set the External PDF Viewer value in Options > Configure TeXstudio > Commands to:

"YOUR PDF VIEWER ADDRESS"  "?am.pdf"

For example mine is:

"C:/Program Files (x86)/Adobe/Acrobat DC/Acrobat/Acrobat.exe"  "?am.pdf"
1
  • Thanks! It works perfectly! Could you please explain what does "?am.pdf" stand for? – Tropilio Nov 30 '19 at 18:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.