2

I always wanted to switch from BibTeX to BibLaTeX, so I thought I'd give it a try today. After some reading on the manual, I eventually managed to convert all commands to the new syntax. Neither pdfLaTeX nor Biber give any errors, however the bbl file is empty and I receive warnings about undefined references and empty bibliographies. I have read many similar problems in this forum, however none of them solved my case. Since the BibLaTeX documentation is one of the few package documentations I have not read completely, I assume i'm naively doing something wrong. My tex file:

\documentclass[fontsize = 11pt,paper = a4,ngerman]{scrbook}

\usepackage[ngerman,british]{babel}
\usepackage[utf8]{inputenc}
\usepackage[backend=biber,bibstyle=authoryear]{biblatex}
\usepackage{csquotes}
\addbibresource{test.bib}

\begin{document}
Test \cite{OLED}.
\end{document}

test.bib:

@Book{OLED,
    author = {Hari Singh Nalwa and Lauren Shea Rohwer},
    title = {Organic Light-Emitting Diodes},
    series = {Handbook of Luminescence, Display Materials and Devices},
    year = {2003},
    publisher = {American Scientific Publishers}
}

Biber gives a version warning in the blg file, even though BibLaTeX 3.0 is installed:

[0] Config.pm:324> INFO - This is Biber 2.1
[0] Config.pm:327> INFO - Logfile is 'Test.blg'
[52] biber-MSWIN:273> INFO - === %a %b %e, %Y, %H:%M:%S
[52] Biber.pm:333> INFO - Reading 'Test.bcf'
[245] Utils.pm:146> WARN - Warning: Found biblatex control file version 2.6, expected version 2.7
[246] Biber.pm:645> INFO - Found 1 citekeys in bib section 0
[262] Biber.pm:2977> INFO - Processing section 0
[282] Biber.pm:3115> INFO - Looking for bibtex format file 'test.bib' for section 0
[286] bibtex.pm:1021> INFO - Decoding LaTeX character macros into UTF-8
[287] bibtex.pm:895> INFO - Found BibTeX data source 'test.bib'

closed as off-topic by moewe, Jesse, Claudio Fiandrino, percusse, Johannes_B Oct 12 '15 at 15:03

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    Your biblatex is too old. Check in the log-file which version is used and where it is located. – Ulrike Fischer Oct 12 '15 at 13:19
  • It was indeed the biblatex version. Very unhappy with how MikTex behaves when you press the 'update' button – Christoph Riedel Oct 12 '15 at 14:21
  • I have never had a problem with updates. Maybe you have a problem with User mode and Admin mode? (Biber is installed in User mode and biblatex in Admin mode or vice versa. Or you haven't installed Biber via the Package Manager at all.) – moewe Oct 12 '15 at 14:25
  • 4
    I'm voting to close this question as off-topic because it was solved by a software update, it was caused by a version mismatch between biblatex and Biber. – moewe Oct 12 '15 at 14:26

Browse other questions tagged or ask your own question.