1

How can I decrease the vspace between a subfloat and its caption? I have already tried this:

\documentclass[fleqn,10pt,twoside,a4paper]{report}
\usepackage[small,sc,bf,nooneline,skip=5pt]{caption} % Nicer formatting of figure captions.
\usepackage{subfig,float}
\captionsetup[subfloat]{captionskip=3pt}
\begin{document}
\begin{figure}
\centering
%%----start of first subfigure----
\subfloat[yyy]{
\label{subfig:a} %% label for first subfigure
\includegraphics[width=10cm]{fig1.eps}}\\[5pt]
%%----start of 2nd subfigure----
\subfloat[xxx]{
\label{subfig:b} %% label for third subfigure
\includegraphics[width=10cm]{fig2.eps}}
\caption{Cap}
\label{fig} %% label for entire figure
\end{figure}
\end{document}

But it doesn't work.

3

Your have loaded the package caption incorrectly.

small, sc, bf, nooneline are not package options. You can use the font setting small, sc, bf with the package options font,labelfont and textfont.

An example:

\usepacakge[labelfont={bf,sc},texfont=small]{caption}

The option nooneline is no longer supported. Instead, use singlelinecheck=off. The documentation of caption listed such changes in the appendix.

The documentation can be found on your computer with

texdoc caption

or CTAN: caption on CTAN

In relation to you minimal example:

\documentclass[demo]{report}
\usepackage{graphicx}
\usepackage{subfig,float}
\usepackage[skip=5pt,font={bf,sc,small},singlelinecheck=off]{caption}
\captionsetup[subfloat]{captionskip=50pt}
\begin{document}
\begin{figure}
\centering
%%----start of first subfigure----
\subfloat[yyy]{
\label{subfig:a} %% label for first subfigure
\includegraphics[width=10cm]{fig1.eps}}\\[5pt]
%%----start of 2nd subfigure----
\subfloat[xxx]{
\label{subfig:b} %% label for third subfigure
\includegraphics[width=10cm]{fig2.eps}}
\caption{Cap}
\label{fig} %% label for entire figure
\end{figure}
\end{document}

enter image description here

  • @Werner: Thanks. You are the native speaker ;-) – Marco Daniel Sep 2 '11 at 19:27
  • No problem. Don't want to be too forward with edits. – Werner Sep 2 '11 at 19:33
  • @Werner: In this way I improve my English. That's a nice gimmick of TeX.sx. ;-) – Marco Daniel Sep 2 '11 at 19:37
  • Thanks for the tip. But the vertical space is still there, isn't it? That gap is exactly what I would like to remove. – sil_leu Sep 3 '11 at 8:31
  • @sil_leu: WHich gap? You can use the option captionskip=50pt (see exeample)? – Marco Daniel Sep 3 '11 at 10:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.