2

I'm using the \c{c} character with the current ACM sigchi template but, in the author's fields, the accents are ignored. They work fine within the body of the paper. Any ideas?

\author{%
  \alignauthor{Do\c{c}a\\
  \affaddr{Insitutions}\\
  \email{[email protected]}}\\
}
6
  • 1
    Welcome to TeX.SX! Please provide more information, i.e. a working document
    – user31729
    Commented Oct 14, 2015 at 14:20
  • Is it possible to attach the document or should I cut-n-paste the file? If the latter, should I keep everything that came with the template? There's a lot of stuff in the template but I'm guessing my snippet wasn't enough.
    – James
    Commented Oct 14, 2015 at 14:33
  • In my experiment after downloading the class, I get “Doça” in the author field.
    – egreg
    Commented Oct 14, 2015 at 15:17
  • Check if somewhere in the template you find \usepackage[T1]{fontenc}, and if not add it to your preamble.
    – Bernard
    Commented Oct 14, 2015 at 16:07
  • This is strange: I do have the \usepackage[T1]{fontenc} line and, in a reduced file, all I get is Doa for the author, rather than Doça.
    – James
    Commented Oct 14, 2015 at 21:24

2 Answers 2

1

You are not supposed to use font packages; the problem is exactly in \usepackage[T1]{fontenc}. The sigchi class defines fonts with \newfont (which is a very silly thing to do), so asking for different fonts and encodings confuses it.

Remove \usepackage[T1]{fontenc}, \usepackage{txfonts} and \usepackage{mathptmx}. Also using microtype does not make sense with this class, unfortunately.

By the way, you should move \usepackage{hyperref} (with no pdftex option) as the last package.

enter image description here

Complain with the authors of the class.

2
  • "not supposed" means that the class authors do not allow it?
    – jarauh
    Commented Oct 27, 2015 at 0:33
  • 1
    @jarauh A class like sigchi is made for printing proceedings of conferences and all papers should have the same format. I believe that the first thing the copy editors will do is removing the font packages.
    – egreg
    Commented Oct 27, 2015 at 9:14
0

I'm not an expert on this, but apparently there's a problem with the font encoding. If you change the font in the title, e.g.:

\title{{\normalsize Do\c{c}a} is still missing the c with the cedilla}

then the cedilla appears. Ok, the result doesn't really look as you would want to have it.

The class file sigchi.cls says that the title is type set with "18pt Helvetica (Arial) bold size". Whatever.

In any case, the first thing that worked on my computer was to comment out the following line:

\usepackage[T1]{fontenc}

So apparently T1 is not the right font encoding for Helvetica cedillas.

It is also possible to change the fontencoding locally, as explained here, in case changing the fontencoding globally for the whole document makes problems elsewhere. However, then it is necessary to change the font to the title font again:

\title{{\fontencoding{OT1}\selectfont\ttlfnt Do\c{c}a} now has the cedilla}

\author{%
\alignauthor{{\fontencoding{OT1}\selectfont\aufnt Do\c{c}a}\\
\affaddr{Insitution}\\
\email{[email protected]}}\\
}

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .