2

I am using TeXShop v3.56 on a MacBook Pro under OX10.8.5. I have generated an .eps plot that I want to include in a paper. When I compile the document, the graph (basically a scatter plot) shows up fine except that it is missing the axis annotation and most of the legend text. It seems that any character that is not numeric (including decimal points) is missing. I can open the .eps file with no problem using Preview (and ghostview) on the Mac. It looks fine. No error messages appear when compiling.

I am loading graphicx and the code for the figure is nothing special:

\begin{figure}[hp]
\begin{center}
\setlength\fboxsep{0pt} 
\setlength\fboxrule{0pt}
\fbox{\scalebox{0.8}{\includegraphics{./check20122014vX.eps}}}
\end{center}
\caption[Log transformed observed chlorophyll (log$_{10}$(C_{obs}))
vs. log$_{10}$(Band Ratio) for MODIS.]  {Log transformed observed
chlorophyll (log$_{10}(C_{obs})$) vs. log$_{10}$(Band Ratio) for
MODIS.} 
\label{fig.chlmbr} 
\end{figure}

I'd appreciate some advice on how to troubleshoot this.

  • SInce your eps image is not known, it is impossible too see, what is koing wrong. Anyway, in your code replace begin{center} ... \end{center} with \centering, omit fbox (it has no function since its rule is zero width) and replace scalebox with option scale in \includegraphics. Maybe will help this – Zarko Oct 14 '15 at 17:41
  • How is your eps image generated? Try to convert it into pdf format, than you will able to use pdflatex (which doesn't support eps images). – Zarko Oct 14 '15 at 17:50
  • I generated the image in IDL (version 8.2). I should add that this used to work. I have not updated or changed IDL since the last time I did this successfully. I have, however, updated TeXShop. I puzzled because the image is fine in both Preview and gv. – Barry Lesht Oct 14 '15 at 18:37
  • Uf, IDL :-), its long, long time ago when I last time used it ... anyway, try the following: (i) include image without any scaling, if this doesn't help (this is expected), then (ii) convert it in pdf with some tool (maybe IDL can export image into pdf format itself) and try again to include it in pdf format. – Zarko Oct 14 '15 at 18:50
  • Thanks for the suggestions. I forgot to mention that I tried the first things you suggested, but they didn't help. As you expected removing the scaling altogether did not help either. I did generate a .pdf from my IDL code, but when I try to import it into the LaTeX document, I get the "no bounding box" error. It is so strange that the numbers and symbols come through fine, but not the alphabetic characters. I posted a query on the IDL board as well - maybe that is where the problem lies. I've also tried eps2eps with no luck. – Barry Lesht Oct 14 '15 at 19:35
1

As Ian suggested, it appears that this problem had nothing to do with TeXShop, but rather with something that seems to have changed in the IDL routine I used to create the eps file. When I specify (in my IDL routine) that I want to use true-type fonts, the graph appears correctly in TeXStop. Thanks for all your ideas.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.