3

I'm trying to format a table using siunitx. There's a column I want to have with scientific notation in which zero-exponents are retained, but the output doesn't put the zero-exponent there even with the retain-zero-exponent option set. I've tried debugging by doing silly things like changing the retain-zero-exponent option setting to being in the preamble and changing the input exponent symbol from E to e but nothing is working.

\documentclass[]{article}
\usepackage{siunitx}

\begin{document}

\begin{table}
\begin{tabular}{c
                S[round-mode=places, round-precision=2, scientific-notation=true, retain-zero-exponent=true]}
{Thing}&     {Number}  \\
   Ex1&     7.91472E0  \\
   Ex2&     7.68513E-6 \\
   Ex3&     3.71188E0  \\
   Ex4&     9.30066E3  \\
\end{tabular}
\end{table}

\end{document
6

This is probably something that could be documented better: what you are seeing is an interaction between scientific-notation and retain-zero-exponent. When you set scientific-notation = true the code is auto-processing all numbers to be in normalised exponent form. That means that you no longer have the situation that the input exponents are retained. Thus retain-zero-exponent has (deliberately) no effect here.

  • I removed the scientific-notation=true from the option flags, and it now works well. It's a slightly annoying fix because in my actual data not all numbers are actually in scientific notation (e.g. a number might be 135.43), and so now I need to go in and convert those manually. Good enough for my particular case though. – efremdan1 Oct 15 '15 at 9:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.