5

I am trying to prevent the abstract from taking up a full page while also using [titlepage]. LaTeX seems to ignore any non-breaking newlines or other formatting directives and places the abstract on a new page regardless.

Using [notitlepage] is unfortunately not an option as I understand, as that leaves the title in its usual size, alignment and formatting and does not give me the beautiful [titlepage] full size title page.

here is a short example to show what I mean:

\documentclass[titlepage]{article}
\usepackage{lipsum}

\begin{document}
\title{Test}
\author{me}

\maketitle

% pagebreak produced here

\begin{abstract}
        \lipsum[1]
\end{abstract}

% unwanted pagebreak produced here

\section{section}
        \lipsum[1]
\end{document}

1 Answer 1

7

Since suppressing the titlepage class option is not desired, one can redefine abstract:

\documentclass[titlepage]{article}
\usepackage{lipsum}

\makeatletter
\renewenvironment{abstract}{%
      %\titlepage
      %\null\vfil
      \@beginparpenalty\@lowpenalty
      \begin{center}%
        \bfseries \abstractname
        \@endparpenalty\@M
      \end{center}}%
     {\par%\vfil\null\endtitlepage
     }
\makeatother

\begin{document}
\title{Test}
\author{me}

\maketitle

% pagebreak produced here

\begin{abstract}
        \lipsum[1]
\end{abstract}

% unwanted pagebreak produced here

\section{section}
        \lipsum[1]
\end{document}

enter image description here

When the titlepage option is in action, the abstract is not typeset in a quotation environment using \small font; if you want this, the redefinition is:

\documentclass[titlepage]{article}
\usepackage{lipsum}

\makeatletter
\renewenvironment{abstract}{%
      %\titlepage
      %\null\vfil
      \@beginparpenalty\@lowpenalty
      \small
      \begin{center}%
        \bfseries \abstractname
        \@endparpenalty\@M
      \end{center}\quotation}%
     {\quotation\par%\vfil\null\endtitlepage
     }
\makeatother

\begin{document}
\title{Test}
\author{me}

\maketitle

% pagebreak produced here

\begin{abstract}
        \lipsum[1]
\end{abstract}

% unwanted pagebreak produced here

\section{section}
        \lipsum[1]
\end{document}

enter image description here

4
  • As I mentioned, I want the full page title, but redefining abstract works perfectly!
    – Azsgy
    Commented Oct 15, 2015 at 19:13
  • Also just noticed, this changes the width of the abstract block, which is normally slightly less wide than normal text. It should be a small fix with some \newgeometry but I think it should be included in case anyone else wants to do this in the future
    – Azsgy
    Commented Oct 15, 2015 at 19:25
  • @Atsch That's the standard behaviour with titlepage option. If you want the behaviour to be the same as without titlepage the redefinition has to be slightly modified. I added it in my updated answer. Commented Oct 15, 2015 at 19:43
  • @GonzaloMedina I guess the end part of your second redefinition of abstract is supposed to contain \endquotation instead of \quotation. Commented Jul 4, 2020 at 15:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .