0

I am using Win8.1 with all updates and Winedt 9 and when compiling using the Winedt console, I get the following message:impossible to start the program because MiKTeX209-core.dll is missing. Please reinstall the programm to correct this error. However, when I start pdflatex from the dos prompt the tex file is compiled. I add that LuaLaTeX from winedt console works correctly. MiKTeX is updated with the latest updates both in admin and user modes. Winedt is also in its latest version. The MWE:

\documentclass{article}
\usepackage[utf8]{inputenc}
\usepackage{slantsc}
\setcounter{secnumdepth}{0}
\pagestyle{empty}
\usepackage[T1]{fontenc}
\usepackage{tgschola}
\begin{document}
  \centerline{\textsc{\large
Please look into the source; if needed, modify it and recompile\rlap.}}
\section{Section}
A section starts here.
\section{A second section}
\section{A third section}
 Section!!
\end{document} 

Any help would be appreciated.

2
  • 1
    @moewe if Xavier really got the unstable version he could go back by using a stable repository: miktex.org/kb/miktex-next Oct 17 '15 at 15:04
  • 2
    @moewe I believe I must have downloaded an experimental version that must have broken something. I have now uninstalled completely MiKTeX and reinstalled it. Updated using the update manager and everything has now worked, at least the 2 test files that I tried. Please accept all my deepest felt apologies for having wasted your time helping me out.
    – Xavier_B
    Oct 17 '15 at 15:28
2

There has been apparently an unapproved or experimental MiKTeX2.9 x64 for Windows available which somehow was downloaded on my machine as the update required for MiKTeX approximately around the 3rd of October 2015. This experimental update includes several files among which several are of the form MiKTeX209-next-*.dll. This experimental update is not good and breaks the pdflatex engine (among others). The best remedy is to uninstall completely the MiKTeX installation using the MiKTeX uninstall program in Control Panel.

2
  • 1
    I don't think "unapproved" is the right word here, experimental is much better. You might also want to add that the experimental repositories are used only when you explicitly ask for them in the updater (there is a clearly marked checkbox). Per Ulrike's comment it would have been enough to revert to the normal repositories instead of uninstalling. It now sounds as if you simply advise uninstalling MikTeX to solve the problem.
    – moewe
    Oct 17 '15 at 16:23
  • You might also want to note that the experimental repositories are specifically not meant to be used on a production system (miktex.org/kb/miktex-next).
    – moewe
    Oct 17 '15 at 16:23
1

When this happens with miktex209-pdftex.dll, execute

initexmf --mklinks --force

and

initexmf --admin --mklinks --force

Source: https://sourceforge.net/p/miktex/mailman/message/35794271/

0

Installing the 32bit version worked for me!

Details: After updating to the latest miktex 2.9, it stopped working and I got the same error. Version 2.8 is not available for download any longer so I decided to try the 32 bit version which is still available: http://ctan.mirror.garr.it/mirrors/CTAN/systems/win32/miktex/setup/windows-x86/basic-miktex-2.9.6753.exe Before installing it in my Windows 8.1 (64 bit), I uninstalled MikTex via control panel and I removed the miktex folder in programs folder. Everything works now :))

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.