1

I know after upgrading to El Capitan, TeXstudio has to be reconfigured the command path in order to function properly. In the question "Reconfiguring TexStudio after upgrade to OS X El Capitan", it has been shown how to change the configuration. But when I go to "TeXstudio" -> "Preferences" -> "Commands" in my TeXstudio (ver 2.10.2), almost all fields show <unknown>. (I install MacTeX 2015 after upgrading to OS X El Capitan, then install TeXstudio.)

"unknown" shown in many fields

According to Herbert Schulz, I should replace every occurance of /usr/texbin with /Library/TeX/texbin. However, in current case I don't know what the original values (containing /usr/texbin) are. It seems possible to manually type every new command letter by letter following that picture in the instruction, but this will easily make mistakes.

Can anyone tell me how to let TeXstudio display the old (but incorrect) values for these commands first so I can replace the path manually, or kindly provide what the correct values for these <unknown> fields are so I can just copy and paste them to my TeXstudio?

1

TeXstudio won't display the old values if it does not detect a program under that path.

The new paths will be detected in the upcoming TeXstudio release 2.10.4. You may try out the release candidate.

Otherwise you'll have to type in the commands or copy them to your settings file. Here's a list of commands from a typical Pre-El-Capitan installation on OS X:

Tools\Commands\asy=/usr/texbin/asy ?m*.asy
Tools\Commands\biber=/usr/texbin/biber %
Tools\Commands\bibtex=/usr/texbin/bibtex %.aux
Tools\Commands\bibtex8=/usr/texbin/bibtex8 %.aux
Tools\Commands\dvipdf=/usr/local/bin/dvipdf %.dvi
Tools\Commands\dvipng=/usr/texbin/dvipng -T tight -D 120 %.dvi
Tools\Commands\dvips=/usr/texbin/dvips -o %.ps %.dvi
Tools\Commands\gs=/usr/local/bin/gs \"?am.ps\"
Tools\Commands\latex="/usr/texbin/latex -src -interaction=nonstopmode %.tex"
Tools\Commands\latexmk="/usr/texbin/latexmk -pdf -silent -latexoption=\"-synctex=1\" %"
Tools\Commands\lualatex="/usr/texbin/lualatex -synctex=1 -interaction=nonstopmode %.tex"
Tools\Commands\makeglossaries="sh -c \"PATH=$PATH:/usr/texbin/; makeglossaries %\""
Tools\Commands\makeindex=/usr/texbin/makeindex %.idx
Tools\Commands\metapost="/usr/texbin/mpost -interaction=nonstopmode ?me)"
Tools\Commands\pdflatex="/usr/texbin/pdflatex -synctex=1 -interaction=nonstopmode %.tex"
Tools\Commands\ps2pdf=/usr/local/bin/ps2pdf %.ps
Tools\Commands\svn="svn "
Tools\Commands\svnadmin="svnadmin "
Tools\Commands\texindy=/usr/texbin/texindy %.idx
Tools\Commands\view-dvi=open %.dvi > /dev/null
Tools\Commands\view-pdf-external=open %.pdf > /dev/null
Tools\Commands\view-ps=open %.ps > /dev/null
Tools\Commands\xelatex="/usr/texbin/xelatex -synctex=1 -interaction=nonstopmode %.tex"
0

A possible solution could be copy all the parameters from the corresponding application TexMaker.

Here an example.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.