1

I recently installed AucTex on a new computer, and am having an issue that I do not recall with regards to accessing environments. Using C-c C-e, auto-complete etc., I am only able to access a handful of environments. Auctex does not detect align, matrix, or any other math environments. It is possible to simply enter the environments by hand, or create custom environments, but this seems tedious for something that I wouldn't expect to be happening. Perhaps there is something I am missing.

closed as off-topic by egreg, Mensch, Svend Tveskæg, Werner, user13907 Oct 29 '15 at 21:24

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Does your document load a package like amsmath? In a regular document without that package, AUCTeX does not autocomplete the align environment for me; but if amsmath is loaded and the buffer has been parsed, then align is an option listed for C-c C-e. – jon Oct 19 '15 at 4:35
  • It does load the package, and I am able to insert the environments manually without a problem. However, it is not detected. Used packages include amsmath,amsthm,amssymb, and a few other math based ones. – zalba19 Oct 19 '15 at 4:41
  • Try closing the buffer with the packages loaded via the usual \usepackage, then reopening it. Then try C-c C-e again. – jon Oct 19 '15 at 4:43
  • Instead of closing/opening, you can use the revert-buffer command – Romain Picot Oct 19 '15 at 5:18
  • 4
    I'm voting to close this question as off-topic because it is about an unspecified issue in the init file, solved in an unspecified way – egreg Oct 29 '15 at 20:50
-1

I ended up solving this issue; turns out the issue was in my init-file. Turns out there a mistake in the file and when it was corrected, everything ended up working correctly. Thanks for the help

Not the answer you're looking for? Browse other questions tagged or ask your own question.