0

I install MikTeX 2.9 on my Windows 8.1 but compilation always fails. Which version of MikTeX is compatible with Windows 8.1?

when i launch a document compilation, i always have the error message below

enter image description here

  • 2
    Welcome, you say the compilation fails, do you mean the document preparation or installation of MikTeX? If the first, you just have faulty code. – Johannes_B Oct 19 '15 at 10:23
  • 2
    There is in general no issue with Win8.1 and MiKTeX 2.9: we will need to see some specific details to help. – Joseph Wright Oct 19 '15 at 10:35
  • 1
    miktex 2.9 works fine in windows 8.1 (and window 10). – Ulrike Fischer Oct 19 '15 at 10:44
  • 1
    Looks like the pdflatex executable is not found. You need to configure your LaTeX editor and tell it where MikTeX is installed, or add MikTeX to the PATH variable. However, I have no idea which editor it is (TeXMaker? TeXStudio?), so I can't really help you with that. – Fritz Oct 20 '15 at 12:06
  • 2
    Possible duplicate of Setting up MiKTeX and TeXworks – Fritz Oct 22 '15 at 15:34
1

It looks like the pdflatex executable is not found. You need to configure your LaTeX editor and tell it where MikTeX is installed, or add MikTeX to the PATH variable.

Here's a toturial on how to add MikTeX to your PATH variable. It should also work for the non-portable version of MikTeX.

  • I have read and the tutorial indicated above, – coliasso Oct 21 '15 at 18:12
  • I have read and the tutorial indicated above, at the step where I would had to paste a path at the PATH location, it wasn't possible (pasting there wasn't allowed); thus, my problem persists. – coliasso Oct 21 '15 at 18:18
  • @coliasso: What do you mean by "pasting there was not allowed"? Can you not write anything there? Or is it just pasting that doesn't work? – Fritz Oct 22 '15 at 11:25
  • I can't paste, nor write there – coliasso Oct 22 '15 at 17:35
  • @coliasso Then that seems to be a problem with your setup (assuming you clicked the right things). I can't really say what the problem might be. However, if you are the administrator of your PC, you could also use the "Edit the system environment variables" dialog and add MikTeX to the System-wide PATH variable, instead of the one for your own user account. – Fritz Oct 22 '15 at 22:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.