I've tried everything I could find (within good reason) regarding how I should proceed in making my TeX files compile again and nothing works. After hunting it down in the computer, I have found that explicitly putting /usr/local/texlive/2014/bin/x86_64-darwin in my path (I have rootless off) seems to work. But I'm absolutely baffled by that path.

Moreover, I don't seem to have the path /Library/TeX/texbin, rather, I have texbin in /Library/Tex/Distributions/Programs/texbin where that folder redirects to the original one located in the /usr directory.

I haven't seen this path with the searching I've done, and I would like to turn rootless on again. Would it be possible to install MacTeX2015 (I have MacTeX2014 currently) and have both my TeXShop and the front end LyX work?

I'm really no good at this stuff, so it's all a little over my head. Any guidance would be appreciated.

  • There are a lot of recent questions about this. My understanding is that the new version of OS X assumes users are idiots and have no interest in having control over the hardware and software they own; however, although my laptop is a Mac I never boot into that side unless absolutely required, so I'm blissfully ignorant even of what version of OS X I run over there. Have you clicked on the "Related" links that show up on the right side of this page -- e.g., like this one?
    – jon
    Oct 19, 2015 at 23:52

3 Answers 3


Installing MacTeX 2015 is the simplest way to get the /Library/TeX/texbin symlink that you're looking for, as currently described on the MacTeX website. This will also allow you to switch TeX distributions, as you could with earlier versions of MacTeX, via the System Preferences pane or TeX Live Utility.

If you don't want to install MacTeX 2015, though, there's nothing wrong with using /usr/local/texlive/2014/bin/x86_64-darwin, and you don't need to turn off the System Integrity Protection ("rootless") feature of the OS. Alternately, this document (pdf) describes how you can create the /Library/TeX/texbin symlink manually.


El Capitan has made some changes related to access to the /usr folder. The /usr folder is now read only even to the admin account. So the tex applications like MacTex are not able to create a symlink /usr/texbin to texbin folder. If you already had an installation of MacTex/Tex in previous OSx versions then the OSx update to El Capitan will remove the /usr/texbin symlink. As mentioned be @Adam in his answer now either you can (re)install latest MacTex or follow the instructions below to symlink the existing Tex installation manually:-

cd /Library/TeX
sudo ln -s Distributions/Programs/texbin texbin
echo "/Library/TeX/texbin" >~/Desktop/TeX
sudo cp ~/Desktop/TeX /etc/paths.d/TeX

Then run the following command to make the path available for current session :-

eval $(/usr/libexec/path_helper -s)

Confirm that the path is available :-

echo $PATH

If you want to rehash the files now, run :-

sudo texhash
  • perhaps it should be said also that only top level /usr is unwritable, sub repertory /usr/local for example has no such restriction.
    – user4686
    Oct 21, 2015 at 7:05

I have installed El Capitan from Scratch and then copied the data from TimeMachine (Migration Assistant).

After that I removed MacTeX 2014 and installed MacTeX 2015. Amazingly /etc/paths.d/TeX was not adjusted, such that $PATH still had /usr/texbin.

I wanted to follow the procedure in Answer #2 but I was not allows to update /etc/paths.d/TeX. But I could delete it and write it again.

This made my TeX work again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .