1

I'm looking for the texmaker.ini file inside my MacBook with OS 10.11. Someone could provide information about the position of the file.

  • @Marijn I already tried both! – Mattia Oct 20 '15 at 9:17
  • in the terminal you could try cd / to go to the root of the filesystem and retry the find . -name "texmaker.ini" from there, possibly sudo find . -name "texmaker.ini" if you have sudo (administrator) rights to prevent access denied errors. If it is not found from the root then the file does not exist. – Marijn Oct 20 '15 at 9:45
  • I wanted to write a similar comment. Although you should, especially when using privileges, limit the search scope. with -x i.e. "sudo find -x . -name "texmaker.ini"" because else you are going to search wherever the filesystems leads. – nonsense Oct 20 '15 at 11:11
  • I tried all the possibilities you (@Marijn and @eject) have suggested but the result provide no file called texmaker.ini. – Mattia Oct 31 '15 at 12:54
1
+50

The texmaker.ini file is created in the user's home and it's stored in

~/.config/xm1

If I do

ls ~/.config/xm1/

the result is

texmaker.ini        texmakerapp.ini

The second file contains just the initialization for the language interface. The start of the first file is

[General]
IniMode=true

[texmaker]
Beamer\Author=
Beamer\BabelDefault=english
Beamer\Encoding=utf8
Beamer\Size=11pt
Beamer\Theme=Warsaw
Color\Background=@Variant(\0\0\0\x43\x1\xff\xff\xff\xff\xff\xff\xff\xff\0\0)
Color\Command=@Variant(\0\0\0\x43\x1\xff\xff\x80\x80\0\0\0\0\0\0)

Please, make certain you have write privileges in the ~/.config directory; as discussed in chat, the result of ls -ld ~/.config should output something like

drwx------  11 foouser  staff  374 Oct 31 15:34 /Users/foouser/.config/

where foouser stands for your user name. If it's root, this means the directory has been created by some application under a sudo regime. Just issue

sudo chown foouser ~/.config

(foouser should be what you see as output of whoami) and then

chmod go-rx ~/.config

Check the output of ls -ld ~/.config and, in case, issue the suitable chmod command,

chmod u+rwx ~/.config

This should solve all your issues, because now Texmaker will be able to save the .ini files in the proper place.

  • Hi egreg, thanks for your support. I checked, but in my ~/.config folder there is no /xm1 directory. – Mattia Oct 31 '15 at 14:05
  • @Mattia What version of Texmaker? – egreg Oct 31 '15 at 14:07
  • Texmaker 4.4.1 it should be the last released (I reinstall MacTeX (TexLive 2015) and Texmaker after the update to El Capitan). – Mattia Oct 31 '15 at 14:09
  • @Mattia I don't know with OS X 10.11, but with 10.9, upon moving away the ~/.config/xm1 directory, launching Texmaker and quitting it recreates the directory. Anyway, the latest release is 4.5. – egreg Oct 31 '15 at 14:12
  • Ok, probably this is related to some changes in paths due to the new OS. Thanks anyway. – Mattia Oct 31 '15 at 14:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.