17

Each time I use autocompletion in TeXstudio for a block environment, e.g.

\begin{itemize}
content...
\end{itemize}

the "content..." is automatically inserted. Is it possible to disable that? It slows me down, because I need to delete it before filling in the contents of the block. I would like the autocomplete to produce just e.g.

\begin{itemize}
                        <-- Just a blank line here
\end{itemize}

A partial solution I found: Use CTRL+RIGHT to jump to the "content..." and overwrite it. But as I said, I would prefer not to have it there at all.

5

You need to disable insert arguments

Go to Options > Configure TexStudio > Make sure that Advanced Options is checked > Completion > Uncheck Insert arguments

  • 7
    Yes, that solves the problem, but some other nice things stop working, e.g. the \end{...} is not properly autocompleted. – Augustin Oct 9 '16 at 11:49
2

In Options > Configure TexStudio > Menu > &Latex > &Environnements, one could change the "Generique" commande by this line :

\begin{%<environment-name%:id:1%>}%\%\\end{%<environment-name%:id:1,mirror%>}

So far, it doesn't affect other autocompletions.

  • This solution doesn't seem to work for Macros that are defined as environments. – kennyB Jan 5 '18 at 23:35
1

I think this might affect some other autocompletions, but this can be done by using the menu Options/Configure TeXstudio/Completion and by disabling 'Use placeholders'.

  • 2
    Yes, that solves the problem, but some other nice things stop working, e.g. the \end{...} is not properly autocompleted in some cases. – Augustin Oct 21 '15 at 10:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.