2

Edit 1:

Following the comment of @kmacinnis, I tried to upgrade my OS X to Yosemite 10.10.5, and finally El Captain 10.11.1; I also deleted everything under ~/Library/Containers/com.apple.Preview/; however I did not touch other things under ~/Library/ because I am not sure which belong to Preview.

The result is that Preview still does not work. Even worse than Yosemite 10.10.1, each time I re-compile by make under a terminal, I have to click on the Preview window to refresh (I did not have to do this under Yosemite 10.10.1, then it goes systematically to the first page.

PS: the Preferences of my Preview: enter image description here

Original Post:

I used to compile tex under Ubuntu and view them with evince or okular. After each re-compilation, the viewers reload automatically the PDF file and stay almost always at the modification location (or last viewed location, which is almost always same as the modification location in practice).

Now, I switch to Mac OS X Yosemite 10.10.1, and I cannot find an ideal reviewer.

With Preview, it does reload the PDF automatically after each re-compilation, but it always goes systematically to the first page.

With Adobe Reader, it does not reload automatically.

With TexShop, the characters are not very clear. And it does not reload automatically for me.

With Skim, which is recommended by many people, the problem is that it flashes one time, and then goes to the modification location. I guess in the first place, it goes to a position and then adjust a little bit. As a consequence, it is annoying.

Does anyone know a better viewer or a solution?

2

Preview will in fact allow you to do what you want, but you have to set the "On opening documents" option in preferences.

enter image description here

6
  • Which OS X are you using? I have exactly the same setting, but it always go to the first page. – SoftTimur Oct 23 '15 at 14:48
  • Yosemite. 10.10.3, although it's never not worked for me, so I don't think it's a 10.10.2 problem. – kmacinnis Oct 23 '15 at 15:29
  • I am downloading Yosemite 10.10.5 (I don't want to try El Capitain, which seems to have a bad feedback)... It does not work on my Yosemite 10.10.1, do you remember if it worked when you used Yosemite 10.10.1? – SoftTimur Oct 23 '15 at 15:41
  • It has always worked, from around Snow Leopard on. I don't pay that much attention to minor version numbers. You might also try deleting ~/Library/Containers/com.apple.Preview/ (and really, any other files in ~/Library/ that clearly belong to Preview.) – kmacinnis Oct 23 '15 at 15:53
  • I just installed Yosemite 10.10.5, and it still does not work. Actually, if i open a PDF, close and re-open it, Preview does go to the last viewed page. However, if the pdf is re-generated (by make in my case from tex file), it goes to the first page. Did you do your test with re-generation / recompilation? Also, there are lots of files under ~/Library/, it is not very clear which files belong to Preview. – SoftTimur Oct 23 '15 at 17:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.