1

I have the problem that I am not able to set the correct space between the footnotes and the footline. There is way too much space yet. Here is an example what it looks like:

enter image description here

I found an example that I can fix it with the geometry-package and set the footkip height using \usepackage[footskip=8mm]{geometry}. The problem is that loading the geometry package even without an option destroys my KOMA layout. Here is the layout without the loaded geometry package:

enter image description here

And this happens when I load the geometry package without any options:

enter image description here

The geometry package destroys alot of the page layout. So how else can I reduce the space between the footnote and the footnoteline? It would be perfect having a space of 1 or 1.5 lines of the height of a line of a footnote. I also tried to lower footheight=1cm in the document class but then I get an error that the footheight is too low.

Here is a MWE:

\documentclass[a4paper, twoside=false, DIV=12, BCOR=5mm, bibliography=totocnumbered, headheight=1cm, footheight=1cm, numbers=autoendperiod]{scrartcl}
\usepackage[multiple, bottom]{footmisc}
\usepackage{layout}
\usepackage{lipsum}

% Set up headers and footers
% Automark fills the \leftmark and \rightmark placeholders with the section and subsection
% Autooneside is needed by automark
\usepackage[automark, autooneside=false, headsepline, footsepline]{scrlayer-scrpage}
\usepackage{xpatch}
\clearpairofpagestyles
\ihead{\ifstr{\rightmark}{\leftmark}{}{\leftmark}}
\ohead{\ifstr{\rightmark}{\leftmark}{}{\rightmark}}
\ofoot{\pagemark~\hspace*{1mm}} 

% Page Style for page which shall contain the page number only
\newpairofpagestyles{pagenumbersonly}{
    \ofoot{\pagemark~\hspace*{1mm}}
}
\AddToLayerPageStyleOptions{pagenumbersonly}{oninit=\KOMAoptions{headsepline=false}}

% Fixing pagestyle for pages containing \section command
\xpretocmd{\section}{\vspace*{1cm}\thispagestyle{pagenumbersonly}}{}{}

%Fixing headline for the bibliography section
\xpretocmd{\bibliography}{\ihead{\leftmark}}{}{}


%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
%% DOCUMENT
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

\begin{document}

    \layout
    \lipsum[10]\footnote{ABC}\lipsum{DEF}\footnote{GHI}\lipsum\lipsum\lipsum

\end{document}

To ensure that no package inferes the layout, these are all of my used packages:

\usepackage[automark, autooneside=false, headsepline, footsepline]{scrlayer-scrpage}
\usepackage[ngerman]{babel}                             
\usepackage[utf8]{inputenc}                         
\usepackage[T1]{fontenc}                                    
\usepackage{lmodern}                                            
\usepackage[all]{nowidow}                                   
\usepackage{microtype}                                      
\usepackage{siunitx}                                        
\usepackage[table]{xcolor}                          
\usepackage{booktabs}                                           
\usepackage{graphicx}                                           
\usepackage{listings, lstautogobble}            
\usepackage{lscape}                                             
\usepackage{pdflscape}                                  
\usepackage{pdfpages}
\usepackage{tikz-er2}                                           
\usepackage{acronym}                                        
\usepackage{changepage}                                     
\usepackage{layout}
\usepackage{amsmath}
\usepackage{amsthm}
\usepackage{amsfonts}
\usepackage{textcomp}
\usepackage{setspace}                                           
\usepackage{lipsum}                                             
\usepackage[multiple, bottom]{footmisc}
\usepackage[fixlanguage]{babelbib}
\usepackage[colorlinks=false, pdfborder={0 0 0}]{hyperref}
\usepackage{xpatch}

Thanks in advance

2

You can change \footskip without loading package geometry:

    \setlength\footskip{30pt}
| improve this answer | |
  • Thanks, that works! I now just have the problem that if there is a footnote, there is a space between the footnote and the text, see: fs5.directupload.net/images/151026/cnov6xsw.png If there is no footnote, the text is directly over the line, without the space: fs5.directupload.net/images/151026/th6x59cx.png Is there a possibility to make this consistent? E.g. having the text, then there is a space of one line of the textheight, then having optionally the footnotes followed by the footsepline? – Drudge Oct 26 '15 at 1:46
  • Okay, it works when I remove footheight=1cm from the document class. Thanks for your answer :) – Drudge Oct 26 '15 at 1:54
3

I think you missunderstood here something. First KOMA-Script does its own calculation of the typing area (DIV=12). You can visualise this with package showframe. Please see too that KOMA-Script introduced a new parameter, not present without KOMA-Script: option footheight.

I changed your code to this MWE (deleted footmisc etc to show the behavior of original KOMA-Script, I added another footnote to have two on one side; please see the comments in the MWE!):

\documentclass[%
  paper=a4, 
  twoside=false, 
  DIV=12, 
  BCOR=5mm, 
  bibliography=totocnumbered, 
% headheight=1cm, % paper top-typing area top       % <=================
% footheight=1cm, % paper bottom-typing area bottom % <=================
  numbers=autoendperiod
]{scrartcl}

\usepackage{showframe} % <=============================================
\usepackage{lipsum}

%\raggedbottom % last line can move                 % <=================
%\flushbottom  % last line always at the bottom     % <=================
%\setlength\footskip{40pt}                          % <=================


\begin{document}
  \lipsum[10]\footnote{ABC}\lipsum[1]\footnote{abc \lipsum[1]} % <======
  \lipsum{DEF}\footnote{GHI}\lipsum\lipsum\lipsum
\end{document}

All changed lines are marked with % <=========. Now please play with the comment signs in this code. You get:

Result of MWE

Your DIV=12 defines the top margin and the foot margin (please the the following image or compile by your own). The size of these margins shows a pretty good typography! That, what you think is an error, is the---for a good typography---wanted footsize of double distance of the headsize! Therefore you can see that the footnote is inside the wanted typing area.

See the third footnote:

enter image description here

You can play with the commands in lines 15 til 17 to change the place of the last line of the side and the \footskip, as mentioned in a comment/answer. And see the changes if you uncomment lines 7 and 8 (see the resulting typing area, shown in the mwe with showframe).

You see, that there is no space too much, no it is good typography! If you change footskip you change the good balance of typing area and footline.

You can use KOMA-Script to change the layout of the footnotes, if you want.

| improve this answer | |
  • Thanks for your answer! It really gave me an insight how the layouting in latex works! Even if it is a pretty good typography and I change the balance of typography and the footline, there are some formal requirements for my bachelor thesis which don't allow me to decide everything on my own :( – Drudge Oct 26 '15 at 2:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.