1

Today I ran the update on my MikTeX 2.9 install on Windows.

After the update, the following started to happen: if I run texify on my document (a MWE consisting of the bare preamble and a single word in the document), the compilation runs fine (I can see it completed in the log) but latex.exe crashes (reported by Windows) before texify returns; similarly, pdflatex.exe crashes after the compilation is completed when run by texify --pdf. The issue disappears if I run texify from an elevated account.

Both latex.exe and pdflatex.exe compile my document without crashes if I run them on their own, even as a regular user.

I have checked the regular user's permission in the most obvious places. I have run initexmf --dump both as admin and as a regular user. Same with "update formats" in Settings. I also checked the log file as produced by pdflatex standalone and when called by texify; the only difference is that when called by texify, full paths are used for all the files.

PdfLatex version:

MiKTeX-pdfTeX 2.9.5700 (1.40.16) (MiKTeX 2.9) Copyright (C) 1982 D. E. Knuth, (C) 1996-2014 Han The Thanh TeX is a trademark of the American Mathematical Society. compiled with zlib version 1.2.8; using 1.2.8 compiled with libpng version 1.6.17; using 1.6.17 compiled with poppler version 0.32.0 compiled with jpeg version 8.4

Any idea what else I could check?

  • Welcome! It uses the same versions either way? Does texify have something like a --debug or --verbose option? (Note that I know zilch about Windows so maybe options work differently there. But hopefully you'll know what I mean, even if I don't.) – cfr Oct 27 '15 at 3:25
  • Yes, I did reboot. For this tests I'm using the command line to avoid a hidden parameter or something from the environment (I usually use WinEdt). So, I type texify b.tex, it compiles and at the end Windows says that latex.exe crashed. If I type latex b.tex or pdflatex b.tex it compiles with no issues. If I run an elevated prompt, texify b.tex compiles without crash. – Martin Argerami Oct 27 '15 at 3:53
  • Yes, I ran the update for both the regular user and the admin user. Same with the other attempts I mentioned above. – Martin Argerami Oct 27 '15 at 14:14
3

So I found the issue. My command line was using the system-wide pdflatex.exe from Program Files, while texify.exe was using the version in the user's appdata\roaming folder. I just copied the exe from the global folder to the local one, and the error disappeared.

The binaries were not identical, although they both reported to be the same version.

  • THANK YOU!! I have been bugged by this issue for a whole month without getting an answer!!! Wow! – Xavier_B Nov 21 '15 at 10:54
  • Glad I could help. – Martin Argerami Nov 21 '15 at 14:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.