4

Like others have noted, after upgrading to El Capitan, there was a required reconfiguration for MacTeX. I completed the fix specified here: https://tug.org/mactex/UpdatingForElCapitan.pdf. So, I changed the Path settings for (pdf)TeX from /usr/texbin to /Library/TeX/texbin in TeXShop preferences, and I changed /usr/texbin/pdflatex to /Library/TeX/texbin/pdflatex and /usr/texbin/xelatex to /Library/TeX/ texbin/xelatex, in BibDesk preferences.

However, if I try to compile a document, I still get the following error report:

/Library/TeX/texbin/pdflatex does not exist. TeXShop is a front end for TeX, but you also need a TeX distribution. Perhaps such a distribution was not installed or was removed during a system upgrade. If so, go to http://tug.org/MacTeX and follow the instructions to (re)install MacTeX. A less likely possibility is that a tool path is incorrectly configured in TeXShop preferences. This can happen if you are using the macports or fink distributions

I’m now not sure if I should really re-install, or am I missing some bit of the fix.

I also tried going to terminal and doing which pdftex, but it returned nothing. Reinstall?

  • 1
    Did you have a previous install of MacTeX or BasicTeX 2015? Check the output of ls -l /usr/local/texlive in Terminal to see if TL 2015 is installed; if not, you'll have to install it or follow the instructions for TL 2014 and earlier in Herb's UpdatingForElCapitan.pdf document. – Adam Maxwell Oct 28 '15 at 5:47
  • ls -l /usr/local/texlive returns: total 0 drwxr-xr-x 20 root wheel 680 Oct 20 2014 2013. So, is the best thing to do just go ahead an install MacTeX? – bozidarka Oct 28 '15 at 5:49
  • 1
    If that directory is empty, I recommend that you install MacTeX 2015, as you've already configured the GUI applications for it. – Adam Maxwell Oct 28 '15 at 5:53
  • @AdamMaxwell Well it is obviously not empty, is it? The comment gives a directory listing. Nonetheless, updating to 2015 is surely to be recommended in this case. No need to delete the old versions - they can happily coexist. (They will also probably work once 2015 is installed and you can switch back using the preference pane if necessary.) – cfr Oct 30 '15 at 3:37
  • @cfr I missed the 2013, because of the way the lines wrapped in the comment. Still, no TL 2015, which is expected by OP's symlinking setup. – Adam Maxwell Oct 30 '15 at 3:45
8

I had the same problem after installing El Capitan.

Did you test if you are able to use pdflatex running from the terminal? In my case it worked.

After knowing that I used which pdflatex to see where the pdflatex is, andthe result was /Library/TeX/texbin/pdflatex. Then I went to this directory, and I noticed that most of its content (including the pdflatex) are actually links to other things, and in the case of pdflatex it is on the path: /usr/local/texlive/2015/bin/x86_64-darwin/.

I changed the path settings in TeXShop to this directory and it solved the problem for me.

  • Perfect answer! Solved my issue within a few seconds after googeling round about 30 minutes :-) – regetskcob Mar 10 '16 at 10:14

Not the answer you're looking for? Browse other questions tagged or ask your own question.