I'm trying to make a handout version of my presentation: i.e., a version with only the last slide on every sequence of slides. After reading around I installed pgfpages and changed:




However, I get the error:

! Class beamer Error: Overprints may not overlap.

(I'll note that the original version of the presentation compiles, no problem.)

Ideas? Am I don't something wrong, is there a different way to make handouts?

  • I'm guessing that somewhere deep in your presentation you use the overprint environment. In all the \onslides (except the one you want shown) add the overlay handout:0. That is, if you have \onslide<2-3> change it to \onslide<2-3|handout:0>. Sep 5, 2011 at 13:06
  • That works: do you want to formally answer the question so I can vote you up?
    – Guy
    Sep 5, 2011 at 13:19
  • Done. (I didn't post it as an answer at first as I wasn't completely sure that this would fix it. There may have been something else as well.) Sep 5, 2011 at 13:36

1 Answer 1


This is due to how beamer collapses slides for the handout version. Unless told otherwise, just about everything ends up on the handout version. Apart from a few cases where it tries to do things correctly (such as \alt commands), it doesn't try to be too clever and work out what clashes with what.

(This is a Good Thing: these decisions are often tricky and should be made by a human. Preferably the one writing the presentation.)

But it can be that you have stuff on a slide that shouldn't be shown together. A simple example might be when using some \onlys for a more complicated set of alternate texts. Something like, \(\pi = \only<1>{3}\only<2>{22/7}\only<3>{3.1415}\). Then its clear that only one of these should be on the handout slide, but beamer will put all of these on by default.

Fortunately, beamer makes it easy to control what goes on a handout frame. An overlay specification can have a "handout-specific" part, which is of the form handout:XYZ. Different parts of the specification are separated by bars, thus a complicated specification could be: <2-3|handout:0|trans:1>. The "default" is for beamer so this reads: "In the beamer mode, show this on slides 2 and 3, in handout don't show it at all, in the transparency mode, show this on slide 1.".

Note the "don't show it at all" in the above. Specifying slide 0 means "don't show".

In the specific case, you are using the overprint environment. Within this one uses \onslides to separate the content and these must have mutually-exclusive overlay specifications (since the material is to be specified on different slides). Since the handout mode collapses them all, even if they are mutually exclusive in beamer they aren't in handout. So we have to make them mutually exclusive again by putting in the "don't show" specification. As it is usual to have only one slide-per-frame in the handout version, this means putting the handout:0 specification on all of the \onslides except one.

Thus inside the overprint environment, change things like:



  • What if one wants in the handout to generate different slides for the different steps of the overprint instead of choosing one? Dec 9, 2015 at 11:08
  • i.e. this would actually mean to temporary disable the handout mode for a single frame. Is it possible? Dec 9, 2015 at 11:10
  • 2
    @gigabytes See tex.stackexchange.com/q/6582/86, I think it does what you want. Dec 9, 2015 at 23:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .