1

On Fedora 22 system: I installed texlive-scheme-full, Python 2.7 (and pygments 2.0.2) as well as all the pre-requisites for minted. I am trying to use the breaklines command with the minted package. I get a package keyval error: breaklines undefined. If I remove breaklines from the \begin{minted} line, the code compiles fine. As well, other parameters like autogobble also generate this error. I also cannot use the \setminted command. So, the minted package loads, but it seems kind of hamstrung. Here is the command that I run: pdflatex -shell-escape -synctex=1 -interaction=nonstopmode "bash_functions".tex.

\documentclass{article}
\usepackage[T1]{fontenc}
\usepackage[english]{babel}
\usepackage{upquote} 
\usepackage{color}
\usepackage{minted}
\AtBeginDocument{%
    \def\PYZsq{\textquotesingle}%
}
\begin{document}
\begin{minted}[linenos=true,breaklines]{bash}
{function h()
#
# Type 'h cmd' instead of 'cmd --help'
#
{
echo "--help" | xargs $1
}

\end{minted}
\end{document}  

closed as off-topic by Stefan Pinnow, Mike Renfro, Mico, Zarko, user13907 Nov 27 '16 at 20:38

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Most probable your system is using an outdated version of the package (the automatic line breaking was recently introduced). Try updating. – Gonzalo Medina Oct 28 '15 at 21:18
  • 2
    I initially thought that having the most recent Pygment package, version 2.0.2, was all that I needed. I checked the time-stamp on the minted.sty file with the command: 'ls -la $(kpsewhich minted.sty)' and it said Sept. 18, 2011. So, I figured that was version 1.7. I then went to: github.com/gpoore/minted and cloned this repository to get version 2.1 which I copied to my Latex/Minted path: usr/share/texlive/texmf-dist/tex/latex/minted and recompiled. It compiled correctly and I now have beautifully formatted code. Thanks for the help! – mgd Oct 29 '15 at 16:20
  • 4
    I'm voting to close this question because it was solved by updating minted package. – Stefan Pinnow Nov 27 '16 at 18:41

Browse other questions tagged or ask your own question.