1

I am using such a document class

\documentclass[11pt%
,a4paper%
,headsepline%
,headinclude=false%
,footinclude=false%
,twoside=true%
,cleardoublepage=empty%
,appendixprefix%
,numbers=noenddot%
,bibliography=totoc%
,listof=totoc%
,openany%
,open = right%                              ,
]{scrbook}

The problem is about the black pages that open = right gives after every chapter that they are not numbered... and I want the blanks to be numbered too

Thanks in advance,

QD

  • 5
    They are numbered, you just don't see it. You want it that way: cleardoublepage=empty – Johannes_B Oct 29 '15 at 16:11
  • @Johannes_B hey yeah I thought so too but I commented it out that did not help – SigniFicar Oct 29 '15 at 16:21
  • cleardoublepage=empty is default. Use cleardoublepage=plain to get the page numbers on pages inserted by \cleardoublepage. – esdd Oct 29 '15 at 16:26
  • 1
    Because that is the default behaviour, use current instead of empty. Wherre did you get the template from? – Johannes_B Oct 29 '15 at 16:26
  • @Johannes_B thanks to you too , the template is from my institute – SigniFicar Oct 29 '15 at 17:08
3

If you are using a KOMA-Script class (or the package scrextend together with a standard class) there is an option to set the page style of blank pages:

cleardoublepage=<page style name>

The default value of this option is empty.

To change the layout of the blank pages you can decide which page style they should use. If there should be only the page number

cleardoublepage=plain

could be a good decision. It is also possible to define an own page style for those pages. As an example see How to make “This page intentionally left blank.” in KOMA script

If the blank pages should have the same page style as the pages before use

cleardoublepage=current

In that case the blank pages behave in the same way as the would do with a standard class.

See the KOMA-Script documentation for additional informations.


Note that it does not make sense to use openany followed by open=right: openany sets open=any and open=right changes the open option back to its default value for scrbook.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.