1

After upgrading to El Capitan I fixed the configuration and it is working fine. But it does not export to html with the tex4ht option. It yields the following output:

"/Library/TeX/texbin/htlatex" "/Users/Me/Documents/test.tex" " " " " " " -interaction=nonstopmode
/Library/TeX/texbin/htlatex: line 2: latex: command not found /Library/TeX/texbin/htlatex: line 3: latex: command not found /Library/TeX/texbin/htlatex: line 4: latex: command not found /Library/TeX/texbin/htlatex: line 5: tex4ht: command not found /Library/TeX/texbin/htlatex: line 6: t4ht: command not found
Process exited with error(s)

I could run htlatex through the command line, so the problem seems to be with TexMaker.

Also updated to texmaker 4.5, and now the error message is:

--- warning --- Can't find/open file `path/file.dvi' --- error --- Can't find/open file `path/file.dvi'
--- warning --- Can't find/open file `path/file.lg'

I also tried running LaTeX first in order to create the dvi file, but it doesn't work.

2

I ran into this same issue using texmaker 4.4.1, but it went away after I updated to 4.5. It looks like 4.5 was only just released on Oct 29.

  • If this is the general solution, it will most likely become obsolete in the future. As such, would it be a good idea to close this question later? – Werner Nov 5 '15 at 1:54
  • Thanks, but I updated to 4.5 and still have problems. Will update the post with more information. – FabiánV Nov 7 '15 at 10:11
  • Did you install MacTeX-2015? Are you able to typeset in TeXmaker? – Herb Schulz Jun 5 '16 at 12:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.