1

I want to write in french, using Lualatex using TexStudio. Therefore, I need to use characters like é, è or à. As Lualatex uses UTF-8 there should not be any problem, but those characters are not displayed. As a workaround, I use \usepackage[T1]{fontenc} but the compiler gives me a warning message (with or without the fontenc package) :

Add \usepackage{fontspec} to the(frenchb.ldf) preamble of your document

Here is a MWE :

\documentclass[a4paper]{article}
\usepackage[french]{babel}
\usepackage[T1]{fontenc}
\begin{document}
    Hi, I want to use characters like :  é, à, è, ï, î.
\end{document}

The problem is : when I add the package fontspec, the compiler gives me an error and the compilation never reaches an end. The error message is the following :

tput: No value for $TERM and no -T specified

Here is a code that generates the error :

\documentclass[a4paper]{article}
\usepackage{fontspec}
\begin{document}
    Hi, I want to use characters like :  é, à, è, ï, î.
\end{document}

EDIT: The problem seems to come from the external call of LuaTex (-shell-escape) needed, in my case, for PGFPlots externalization.

closed as unclear what you're asking by egreg, Zarko, Claudio Fiandrino, Martin Schröder, Jesse Nov 3 '15 at 14:12

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Never seen this before. But make sure not to use minimal for any example or tests. It is meant for something completely different but has this confusing name. – Johannes_B Oct 31 '15 at 15:28
  • @Johannes_B Thank you for the remark, I edited my post accordingly. – Mammouth Oct 31 '15 at 15:31
  • 1
    I experience no problems with the code you say generates an error. Which operating system, TeX distribution, and version of LuaTeX and fontspec do you use? – Mico Oct 31 '15 at 15:47
  • 1
    Don't use fontenc with lualatex. – Martin Schröder Oct 31 '15 at 19:09
  • @Mico My operating system is Max OS X Yosemite (10.10.5) with TexLive. Everything is up-to-date so the LuaTex version is 0.8 and fontspec is v2.4e. I tried on a different computer with the same configuration an the error is the same... @MartinSchröder Could you explain why ? And maybe a better solution ? – Mammouth Nov 1 '15 at 9:24
0

Too long for a comment and partially an answer:

I'm using this MWE for Emacs:

\documentclass[a4paper]{article}
\usepackage{fontspec}
\begin{document}
    Hi, I want to use characters like :  é, à, è, ï, î.
\end{document}

%%% Local Variables:
%%% TeX-master: t
%%% TeX-PDF-mode: t
%%% TeX-engine: luatex
%%% TeX-command-extra-options: "-shell-escape"
%%% End:

Please make sure that -- after saving the file -- you run the command TeX-normal-mode, usually bound to C-c C-n . Then compile. Works here on Windows...

Not the answer you're looking for? Browse other questions tagged or ask your own question.