0

I would like to change the English "and" to the German "und" when I cite two authors with /parencite. I'm using Bibdesk for my bibliography.

\usepackage{acronym}        
\usepackage[utf8]{inputenc}
\usepackage{german}
\usepackage{chngcntr} 
\usepackage[style=authoryear]{biblatex}
\usepackage{nameref}

\addbibresource{refrences3.bib}
\renewcommand*{\nameyeardelim}{\addcomma\space}
\renewcommand*{\mkbibnamelast}[1]{\textsc{#1}} 

If I use \usepackage[ngerman]{babel}, I get the following errors:

./Introduction.tex:60: Undefined control sequence.
\bbl@nonfrenchspacing ->\sfcode `\.3000\sfcode `\?
                                                  3000\sfcode `\!3000\sfcode...
l.60 \begin{document}

./Introduction.tex:60: Undefined control sequence.
\lbx@lfromlang ->\iffieldundef 
                               {origlanguage} {} {\bibstring {from\thefield ...
l.60 \begin{document}

./Introduction.tex:60: Undefined control sequence.
\lbx@lfromlang ...f {origlanguage} {} {\bibstring 
                                                  {from\thefield {origlangua...
l.60 \begin{document}

./Introduction.tex:60: Undefined control sequence.
\lbx@lfromlang ...} {} {\bibstring {from\thefield 
                                                  {origlanguage}}\space }
l.60 \begin{document}

./Introduction.tex:60: Undefined control sequence.
\lbx@sfromlang ->\iffieldundef 
                               {origlanguage} {} {\bibstring {from\thefield ...
l.60 \begin{document}

./Introduction.tex:60: Undefined control sequence.
\lbx@sfromlang ...f {origlanguage} {} {\bibstring 
                                                  {from\thefield {origlangua...
l.60 \begin{document}
  • 1
    Welcome to TeX.SX! Have you tried \usepackage[ngerman]{babel} ? – Tom Bombadil Nov 2 '15 at 17:24
  • This would work but i get a lot of Errors – Jaka11 Nov 2 '15 at 17:41
  • 1
    Remove the quite old \usepackage{german} and use \usepackage[ngerman]{babel} (or for old orthography rules \usepackage[german]{babel}). You will have to remove the temporary files (.aux, .bbl, .bcf) before re-compiling. – moewe Nov 2 '15 at 17:42
  • 2
    Kick out package german, trash all the auxiliary files and start compiling again. – Johannes_B Nov 2 '15 at 17:43
  • If you still get the error after removing \usepackage{german} and clearing auxiliary files, please prepare a full MWE? – moewe Nov 2 '15 at 18:07
1

Instead of using the package german use babel with the appropriate language as a package option, ngerman in your case (unless you want the "alte deutsche Rechtschreibung", in which case it would be german). You can also supply more than one language, where the last langauge will be the main one: \usepackage[english,ngerman]{babel} means that your document uses english and german, with german being the main language.

babel will also localize the captions of lists of floats, the table of contents, in float captions and others. If you don't like the standard values, here are the most common redefinitions when you use a Koma documentclass:

\renewcaptionname{ngerman}{\contentsname}{Inhalt}
\renewcaptionname{ngerman}{\listfigurename}{Abbildungen}
\renewcaptionname{ngerman}{\listtablename}{Tabellen}
\renewcaptionname{ngerman}{\figurename}{Abb.}
\renewcaptionname{ngerman}{\tablename}{Tab.}

or if you don't:

\addto{\captionsngerman}%
{ \renewcommand*{\contentsname}{Inhalt}
  \renewcommand*{\listfigurename}{Abbildungen}
  \renewcommand*{\listtablename}{Tabellen}
  \renewcommand*{\figurename}{Abb.}
  \renewcommand*{\tablename}{Tab.}
}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.