Why am I getting this error? This is my preamble which I include in the main document. My document is EMPTY. This worked before, but then I had to do a system restore and reinstall miktex and texmaker. the bibliography program is now set to biber and miktex is 64 version.

% ================================Präambel==============================
% Kodierung, Sprache, Patches {{{
\usepackage[T1]{fontenc}    % Ausgabekodierung; ermoeglicht Akzente und Umlaute
                            %  sowie korrekte Silbentrennung.
\usepackage[utf8]{inputenc} % Erlaub die direkte Eingabe spezieller Zeichen.
                            %  Utf8 muss die Eingabekodierung des Editors sein.
\usepackage[ngerman]{babel} % Deutsche Sprachanpassungen (z.B. Ueberschriften).
\usepackage{microtype}      % Optimale Randausrichtung und Skalierung.
    ]{csquotes}             % Korrekte Anfuehrungszeichen in der Literaturliste.
%\usepackage{fixltx2e}       % Patches fuer LaTeX2e. %not needed according to debugger
\usepackage{scrhack}        % Verhindert Warnungen mit aelteren Paketen.
% }}}

% Schriftarten {{{
\usepackage{mathptmx}       % Times. Package 'times.sty' is obsolete.
% }}}

% Text durchstreichen mit \sout; Option 'normalem' verhindert,
% dass das Makro \emph{} umdefiniert wird.  

% ok-zeichen usw

% Biblatex {{{
     ]{biblatex}             % Biblatex mit alphabetischem Style und biber.
 \bibliography{resources/Literatur}% Dateiname der bib-Datei.
% }}}

% Dokument- und Texteinstellungen {{{
    ]{geometry}             % Ersetzt 'a4wide'.
\clubpenalty=10000          % Keine Einzelzeile am Beginn eines Paragraphen
                            %  (Schusterjungen).
\widowpenalty=10000         % Keine Einzelzeile am Ende eines Paragraphen
\displaywidowpenalty=10000  %  (Hurenkinder).
\usepackage{floatrow}       % Zentriert alle Floats.
\usepackage{ifdraft}        % Ermoeglicht \ifoptionfinal{true}{false}
\pagestyle{plain}           % keine Kopfzeilen
% \sloppy                     % großzügige Formatierungsweise
\deffootnote{1em}{1em}{\thefootnotemark.\ } % Verbessert Layout mehrzeiliger Fußnoten

        pdftitle = {\@title},
        pdfauthor  = \@author,
% }}}

% Weitere Pakete {{{
\usepackage{graphicx}       % Einfuegen von Graphiken.
\usepackage{tabu}           % Einfuegen von Tabellen.
\usepackage{multirow}       % Tabellenzeilen zusammenfassen.
\usepackage{multicol}       % Tabellenspalten zusammenfassen.
\usepackage{booktabs}       % Schönere Tabellen (\toprule\midrule\bottomrule).
\usepackage[nocut]{thmbox}  % Theorembox bspw. fuer Angreifermodell.
\usepackage{amsmath}        % Erweiterte Handhabung mathematischer Formeln.
\usepackage{amssymb}        % Erweiterte mathematische Symbole.
    ]{acronym}              % Abkuerzungsverzeichnis.
    textsize=tiny,          % Notizen und TODOs - mit der todonotes.sty von
    \ifoptionfinal{disable}{}%  Benjamin Kellermann ist das Package "changebar"
    ]{todonotes}            %  bereits integriert.

\usepackage{listings}       % Spezielle Umgebung für...
    \lstset{                %  ...Quelltextformatierung.
% }}}


    parskip=half,           % Ersetzt manuelles setzten von parskip/parindent.
    numbers=noenddot,       % Entfernt den letzten Punkt der Kapitelnummern.
    open=any,               % Kapitel kann auf jeder Seite beginnen.
%   final                   % Entfernt alle todonotes und den Entwurfstempel.

% ================================Präambel==============================
% ==========================Dokumentinformationen=========================
%% ===============PDF-Einstellungen inkl Dokument-Infos===================
% ============================Tooltip-Script==============================
% ================================Dokument==============================
  • 1
    Normally, this error can't occur, unless you are allocating many counters in a loop
    – user31729
    Nov 2, 2015 at 20:39
  • 1
    @DBRN --- It's best to keep things as simple as possible: avoid loading packages unless you need them. Nov 2, 2015 at 21:22
  • 1
    yes was looking tex.stackexchange.com/questions/251834/… Nov 2, 2015 at 21:26
  • 2
    why are you loading mathptm, heleve and lmodern all at the same time? Do you want your main body font to be times or latin modern, it can't be both ? setting widow and clubpenalty that way will have mostly bad effects, Nov 2, 2015 at 21:29
  • 2
    This example is incredibly non-minimal. If you throw your whole house and the kitchen sink into a document, you can expect some strange side-effects, and this appears to be one of them. Do you really need all those packages? In any case, adding \usepackage{hyperref} and removing \usepackage{etex} solved the problem on my end; the process of producing a minimal example would almost certainly have revealed this to you. Nov 2, 2015 at 21:47

1 Answer 1


Normally in old (pre-2015) with etex package, not post 2015 latex releases 9when etex package should not normally be used) you will not get this error unless you use over 30 thousand counts, which is unlikely.

However you also get it in old latex releases if you use too many inserts (you can only have 250 of them) floatrow mistakenly uses \newinsert rather than \newbox in one place which doesn't affect the behaviour unless you run out of inserts.

In the 2015/10/01 latex release, \newinsert was changed so that you are very unlikely to run out of inserts (as there 52 boxes pre-allocated for use by floats and (now) inserts).

Thus your example runs without error in current latex releases if you delete


and add


Note hyperref must always have been needed it could not have "worked before" as it uses hyperref features without loading the package.

  • This was a really cool answer. I faced a similar problem using biblatex package, but by changing \newinsert to \newbox the error vanished.
    – Prelude
    May 22, 2017 at 14:07
  • 1
    @Prelude so you have an old latex release? (also you can not change \newinsert to \newbox in general, it was a specific issue with a mistaken use in floatrow) May 22, 2017 at 14:09
  • @David_Carlisle yes, I have and old version at work and this cannot be updated due to administrative restrictions. anyhow such errors for not so professional users such as me are pretty hard to find, so such answers could be really helpful.
    – Prelude
    May 22, 2017 at 14:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .