5

The Issue

I am attempting to have a figure placed at the top of the following page, but LaTeX is insisting on placing it on it's own page, after the bibliography.

What I've Tried

  • Using \clearpage and \newpage in various places
  • Placing the figure on it's own page, inserted after the page I want it to follow, but before the bibliography
  • Using the [!ht], and \usepackage{float} with [H]
  • Using the placeins package, along with the [section] option and an explicit \FloatBarrier after the figure, prior to the bibliography

None of it has worked.

What am I missing?

MCVE:

This is a modular document

dave.tex

\documentclass[man,12pt]{apa6}
\usepackage[utf8]{inputenc}
\usepackage[american]{babel}
\usepackage{csquotes}
\usepackage[style=apa,backend=biber]{biblatex}
\DeclareLanguageMapping{american}{american-apa}
\usepackage{subfigure}

\bibliography{mybib}

% This is here to take advantage of the apa6 class' running header
% and page numbering, but I've defined my own title page to suit
% title page requirements at Colorado Technical University. This
% customized title page is not compatible with the jou option for
% the apa6 document class, as of October 31st, 2015. You have to
% use \maketitle, otherwise the two column formatting will be broken.

\title{a}
\shorttitle{b}
\author{c}
\affiliation{d}
\date{e}

\begin{document}
    % \abstract{}
    % \keywords{}
    \include{bob}

\nocite{*}
\printbibliography
\end{document}

bob.tex

\section{Bob's page}

    This is bob's page. Hello.

    Lorem ipsum dolor sit amet, consectetur adipiscing elit. Vestibulum tempor ut augue id placerat. Suspendisse in sapien quis nulla scelerisque blandit vitae vitae risus. Nunc id ligula vehicula, imperdiet urna eu, tincidunt ante. Phasellus laoreet lorem eu nisl venenatis, ut hendrerit odio molestie. Nam a suscipit erat, vitae mollis eros. Vivamus congue diam enim. Nullam vestibulum purus eu elit volutpat, ut aliquet ligula laoreet. Suspendisse sagittis hendrerit justo accumsan consectetur. Integer non nisi elit. Quisque ac elit mauris. Curabitur malesuada fermentum lacus vel elementum. Donec ultricies suscipit turpis congue viverra. Cras eleifend diam lobortis, aliquet diam vel, euismod odio.

    Sed tincidunt vulputate tellus nec luctus. Mauris scelerisque lacinia iaculis. Pellentesque a dui eu dui porta hendrerit sit amet ac tellus. Sed condimentum, mi ac consequat scelerisque, dui dolor mattis nulla, pretium aliquam libero ipsum id urna. Aenean at lacinia ligula, quis varius mi. Nunc at efficitur quam, vel ullamcorper sapien. Vivamus erat nunc, rutrum eget scelerisque nec, vestibulum nec mauris. Suspendisse volutpat, diam at elementum dapibus, ipsum mi varius ante, vel consectetur magna tellus vitae mi.

    Suspendisse nisi dui, efficitur nec mollis et, tempor sit amet risus. Fusce consequat purus at neque tincidunt, sed vehicula mauris vehicula. Phasellus vulputate tincidunt dolor id facilisis. In nisi est, pretium vel euismod ac, convallis vitae lorem. Vivamus tempor neque nunc. Phasellus pulvinar varius orci in vulputate. Sed lobortis ante eros, a placerat urna molestie et.

    Cras cursus pharetra venenatis. Morbi sit amet neque tincidunt, consequat metus nec, euismod erat. Integer odio turpis, lobortis ut urna non, sagittis consectetur tellus. Praesent ut purus at enim accumsan dapibus. Suspendisse nulla tortor, commodo feugiat blandit sit amet, tempor sed eros. Curabitur pretium magna fringilla pharetra varius. Vivamus leo libero, laoreet vel aliquam tristique, aliquet eget nunc.

\begin{figure}[!ht]
    \begin{subfigure}
        \centering
        {\includegraphics[width=2.5in]{htmlExample}}
    \end{subfigure}
\end{figure}

mybib.bib

@ONLINE{tug14,
    author = {{{\TeX} Users Group}},
    title = {{Just What is {\TeX}}?},
    year = {2014},
    url = {http://www.tug.org/whatis.html}    
}
2
  • 1
    The option man you used caused this behaviour. Delete it or comment is and you will have the image after the text. Tip: please see that we do not have your picture. Use instead of your pictures the image examples contained in package mwe. It has only to be installed but must not be called explicitly ...
    – Mensch
    Nov 4 '15 at 4:54
  • Well, since the man option causes that behavior, is there a way to override it that you know of? Or will I need to take a deeper look at the package for myself? Also, if you could please put your comment in as an answer so that I can accept it. Thanks for your help here, I will utilize the mwe package for examples from here on out.
    – nihilon
    Nov 7 '15 at 2:54
3

Well, in the manual for class apa6, Chapter 3 you can read:

Document mode: Three choices are available.

  • jou (default): Formats the document with an appearance resembling a jou printed APA journal (e.g., Journal of Educational Psychology. The text is typeset in two-sided, two-column format.
  • man: Formats the document in close (if not complete) compliance with the man requirements for submission to an APA journal (e.g., title page, double-spacing, etc.).
  • doc: Formats the document as a typical L A T E X document (one-sided, single-doc column, etc.)

So, option man causes the behaviour. Delete it or comment it and you will have the image after the text.

I do not know the class apa6 well, so I can't give you a hint if or how you can change the code or patch it to get what you need.

A personal remark:

If you have to submit a paper with this class do it without changes! They will not be used to print the paper in the journal.

If your document has not to be submitted using this class choose another one or use better usual classes article, report or book. I do not know if there is a licence that you are allowed to use this class for other journals ... Be careful, do not use classes you are not allowed to ...

1
  • This isn't for submission to a journal, fortunately. It's a for school assignments. My school requires papers to be in APA 6 format, and I despise Word. Which is how I ended up finding LaTeX. Thanks for the answer!
    – nihilon
    Nov 7 '15 at 5:13
9

This is an old thread, but I had the same question as the OP. I went to the apa6 manual to read up on the man class. I noticed the option for floatsintext, which is described as: In man mode, integrates floats (tables and figures) within the body of the text instead of postponing them until after the reference list.

Worked like a charm for me, and I thought I'd add it here in case anyone else has the same issue.

2
  • 1
    I've been wasting hours finding a solution. And then it's that easy...
    – BurninLeo
    Sep 28 '17 at 10:46
  • this should be the answer!
    – Zhiya
    Jul 5 '19 at 2:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.