1

I encounter this problem with both the MSCS style file, which is not a standard LaTeX package but an in-house style of Cambridge Journals, and also with the ACM sigplanconf style. I'm not sure if it's appropriate to ask about in-house styles here, but if so I would appreciate some help. I don't believe this is related.

I get a spurious period at the end of bibliography items whenever they contain DOIs, as shown below (the very last period should not be present): enter image description here

Here's the code for the above; you'll need to put mscs.cls in the same folder.

\documentclass{mscs}
\usepackage[authoryear]{natbib}

\begin{filecontents*}{bib.bib}
@article{milner92,
 author = {Robin Milner and Joachim Parrow and David Walker},
 title = {A Calculus of Mobile Processes, {I} and {II}},
 journal = {Inf. Comput.},
 volume = {100},
 number = {1},
 pages = {1--77},
 year = {1992},
 doi = {10.1016/0890-5401(92)90009-5},
}
\end{filecontents*}

\begin{document}
\citep{milner92}

\bibliographystyle{plainnat}
\bibliography{bib.bib}

\end{document}

Note: natbib doesn't seem to be essential to the problem, but I would like a solution that works with it.

1
2

For some (weird) reason, this spurious period is due to the doi field be filled. If you remove it, the bibliography prints properly:

\documentclass{mscs} % Downloaded from ftp://ftp.cup.cam.ac.uk/pub/texarchive/journals/latex/mscs-cls/unpacked/mscs.cls
\usepackage[authoryear]{natbib}
\begin{filecontents*}{bib.bib}
@article{milner92,
author={Robin Milner and Joachim Parrow and David Walker},
title={A Calculus of Mobile Processes, {I} and {II}},
journal={Inf. Comput.},
volume={100},
number={1},
pages={1--77},
year={1992},
}
\end{filecontents*}

\begin{document}
\cite{milner92}

\bibliographystyle{plainnat}
\bibliography{bib}
\end{document}

enter image description here

Yes, this is silly and their style should implement doi's, which are really convenient. If you're planning to submit to that journal, I guess they will re-format your bibliography anyhow, so my advice would be not to spend too much time to adapt their bibliographic style.

3
  • 1
    I changed my mind about accepting this answer (although it's helpful), as the problem also arises with sigplanconf. So the problem seem to be particular to DOIs, rather than the MSCS style per se. Unfortunately removing DOIs isn't a good option for me, so I really need a fix that works generically with natbib. Also updated my question. – Roly Jan 13 '16 at 12:53
  • @Roly I would upvote your question a socend time, if that was possible ;-). You should provide an example file which reproduces your problem with Sigplanconf. – Clément Jan 13 '16 at 16:59
  • Agreed. I will do that next week once my deadline has passed! – Roly Jan 13 '16 at 19:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.