0

I'm currently using the mla style for citations \usepackage[style=mla,sorting=anyt]{biblatex}, however it does not support @online sources. Is there any way to get the URL in the footnote when using \footcite? Or is there a style similar to mla with support for online sources?

Edit:

\documentclass[12pt,a4paper]{scrartcl}
\usepackage[style=mla,sorting=anyt]{biblatex}
\addbibresource[datatype=bibtex]{sources.bib}
\begin{document}
The Commonwealth has a history\footcite{Commonwealth2015}

sources.bib:

%Created with JabRef 2.10
@Online{Commonwealth2015,
  Title                    = {Our history {\textbar} The Commonwealth},
  Author                   = {The Commonwealth},
  Url                      = {http://thecommonwealth.org/our-history},
  Year                     = {2015},
  Urldate                  = {2015-11-05},

  Timestamp                = {2015.11.05}
}    
  • Welcome to TeX.SX! Would you mind providing a minimal example, also with a minimal bib so that peaople can copy it to tinker? – Tom Bombadil Nov 5 '15 at 12:27
  • Please see footcite not getting displayed – moewe Nov 5 '15 at 14:19
  • @moewe Thanks for the link, I kinda managed to add a footcite driver, although I have a really hard time understanding how to properly write a \DeclareBibliographyDriver{}. Any more resources on this would be greatly appreciated. – ProgrammingMachine5000 Nov 5 '15 at 14:31
1

The MLA style for biblatex has not been updated since 2013, there have been some changes to biblatex that make the style not work particularly smoothly any more, plus there are some bits that are simply not implemented.

We can get \footcite to work with @online sources with

\DeclareBibliographyDriver{footcite:online}{%
  \usedriver
    {\renewbibmacro*{bbx:savehash}{}}
    {online}}

You can make sure to see URL info and the like with the option noremoteinfo=false.

MWE

\documentclass{article}
\usepackage[ngerman]{babel}
\usepackage[babel,german=guillemets]{csquotes} 
\usepackage[style=mla,sorting=anyt,noremoteinfo=false]{biblatex}

\usepackage{filecontents}
\begin{filecontents*}{\jobname.bib}
@Online{Commonwealth2015,
  Title                    = {Our history {\textbar} The Commonwealth},
  Author                   = {{The Commonwealth}},
  Url                      = {http://thecommonwealth.org/our-history},
  Year                     = {2015},
  Urldate                  = {2015-11-05},
}   
\end{filecontents*}

\addbibresource{\jobname.bib}


\DeclareBibliographyDriver{footcite:online}{%
  \usedriver
    {\renewbibmacro*{bbx:savehash}{}}
    {online}}

\begin{document}
The Commonwealth has a history\footcite{Commonwealth2015}

\printbibliography
\end{document}

enter image description here

Maybe you can find another style that suits your needs as you are likely to run into more problems as you make your way through a big project.

|improve this answer|||||
  • Well thanks for that answer, but I've tried like 5 other styles but mla seems to be the only one mentioning the booktitle in the footnotes. This would pretty much be the only criterion a style would need to support. If you have any good recommendations I'm more than happy to switch to any other style. – ProgrammingMachine5000 Nov 5 '15 at 14:52
  • @ProgrammingMachine5000 Maybe one of the verbose family is for you. You can find style examples in the doc/examples directory on CTAN. – moewe Nov 5 '15 at 14:57
  • 1
    Just tried the verbose-inote and I think I'm going to stick with that one, will have a look at the other ones though. Thanks a lot! – ProgrammingMachine5000 Nov 5 '15 at 17:11
1

Footnotes in the MLA style dropped out of the MLA Handbook back in 2009 update. They're in the current biblatex-mla package, but they're bottom of the list as far as priorities go, and I would need more time out of my job to add much more functionality or update them to something looking better with the recent 2016 update to the MLA Handbook.

Unfortunately, if footnotes are important to you, then the biblatex-mla package is probably the wrong one.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.